summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-23 20:51:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-23 20:52:13 +0200
commit17aacbc60c99c7d340305f0126113fd979478b2b (patch)
treebeb8ab7975aac6feeb747a3238ba8bf785bb7749 /sci-libs/branca
parentsys-apps/intune-portal: Add version 1.2405.17, drop old 1.2404.23 (diff)
downloadgentoo-17aacbc60c99c7d340305f0126113fd979478b2b.tar.gz
gentoo-17aacbc60c99c7d340305f0126113fd979478b2b.tar.bz2
gentoo-17aacbc60c99c7d340305f0126113fd979478b2b.zip
sci-libs/branca: add 0.8.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/branca')
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.8.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index 1bf88c0e58c3..44ea8a6b6b7c 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1,3 +1,4 @@
DIST branca-0.7.0.tar.gz 42990 BLAKE2B b8de083b0b94d35dbb6df5d230e388832fe027d756767d24ae8091f25d9846ac1f2ae72799aa83583c99ec02d955c7f8cb80183f1543e503d0a802ce051acac5 SHA512 bfe6afd93752dda57e55ba7bdd433e079b51798056b2be8d9c19d4ccc4ed94cc95b733cabf0981c908887c1f8a96e16bd11cb1b495243ac91df4c1c1c1253282
DIST branca-0.7.1.tar.gz 43005 BLAKE2B 2f2834d87e32ef5507273b14b1b8fcebc33d7eae49e0ffb8e834c540b1a329d177805ccbc1441cd522092d396ba98f69f3c8ab95254068d7b352e6f7df52c60d SHA512 70b6e361e93a01c319928890a40e3aa1e887e718b0736afe0a65bc45fe56fe6ca24a4c50db099066d84876cc8efd540a5cc14aa48607671ac068df3ae5124d29
DIST branca-0.7.2.tar.gz 42586 BLAKE2B 3bb6a1f93babb80788fbc1cbd37d8b0c2d5c975c9a98c5816298e37a447bcffb7742a768a0ad2fbb58af5ce0650ef28fdef42e8e4d505bbf29ab10c87ed388d6 SHA512 ad62e4496b43405dbc54b2cca35ee9d0265b8deeeb3df3b0868e63e6890fe491bfc4987318d74c1e78d83f05bdf56bfd570609699860ab1af9d189357bf00107
+DIST branca-0.8.0.tar.gz 43075 BLAKE2B 46779d59ca981c1f6e76193b1776c77a7c455b67d93115027b17f96b8c4df737502dc32feb6ce242e0f2fec9ed4541ed79c6856e85d740dec40d092000873b32 SHA512 b5e8ac51a5d1b70ee72066ee16c9fc8d37623ca807c67cf0f5a2daba37f901ecd9eb81b03857c222ace1f36fb71a9a348aae7079deccf657eaabcc1dc6b64158
diff --git a/sci-libs/branca/branca-0.8.0.ebuild b/sci-libs/branca/branca-0.8.0.ebuild
new file mode 100644
index 000000000000..6fbc4495a341
--- /dev/null
+++ b/sci-libs/branca/branca-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.0-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs/source \
+ dev-python/nbsphinx
+
+python_test() {
+ epytest -m 'not headless'
+}