summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Zigo <tomas.zigo@slovanet.sk>2022-10-31 11:17:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-11-18 10:22:51 +0200
commitf0a989860180ae3ff1a05c08d935e6afc2e373be (patch)
treed511d5d8abc1ee1d7ae817526f700fd2ac154339 /sci-geosciences
parentapp-emulation/virtio-win: add 0.1.255.2 (diff)
downloadgentoo-f0a989860180ae3ff1a05c08d935e6afc2e373be.tar.gz
gentoo-f0a989860180ae3ff1a05c08d935e6afc2e373be.tar.bz2
gentoo-f0a989860180ae3ff1a05c08d935e6afc2e373be.zip
sci-geosciences/grass: remove unused compilation configuration --with-wxwidgets option
Signed-off-by: Tomas Zigo <tomas.zigo@slovanet.sk> Closes: https://github.com/gentoo/gentoo/pull/28050 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/grass-8.2.0-r2.ebuild12
-rw-r--r--sci-geosciences/grass/grass-8.2.0.ebuild12
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild12
3 files changed, 6 insertions, 30 deletions
diff --git a/sci-geosciences/grass/grass-8.2.0-r2.ebuild b/sci-geosciences/grass/grass-8.2.0-r2.ebuild
index 284209a9365c..40184550c75b 100644
--- a/sci-geosciences/grass/grass-8.2.0-r2.ebuild
+++ b/sci-geosciences/grass/grass-8.2.0-r2.ebuild
@@ -5,9 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
-WX_GTK_VER="3.0-gtk3"
-inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -154,11 +153,6 @@ src_prepare() {
}
src_configure() {
- if use X; then
- local WX_BUILD=yes
- setup-wxwidgets
- fi
-
addwrite /dev/dri/renderD128
local myeconfargs=(
@@ -192,7 +186,6 @@ src_configure() {
$(use_with opencl)
$(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
- $(use_with X wxwidgets "${WX_CONFIG}")
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
$(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
$(use_with X x)
@@ -265,8 +258,7 @@ os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
-i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
if use X; then
- local GUI="-gui"
- [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ local GUI="--gui"
make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
doicon -s 48 gui/icons/${PN}-48x48.png
fi
diff --git a/sci-geosciences/grass/grass-8.2.0.ebuild b/sci-geosciences/grass/grass-8.2.0.ebuild
index 2fa97add74b3..b5338b1fef9b 100644
--- a/sci-geosciences/grass/grass-8.2.0.ebuild
+++ b/sci-geosciences/grass/grass-8.2.0.ebuild
@@ -5,9 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
-WX_GTK_VER="3.0-gtk3"
-inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit autotools desktop python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -148,11 +147,6 @@ src_prepare() {
}
src_configure() {
- if use X; then
- local WX_BUILD=yes
- setup-wxwidgets
- fi
-
addwrite /dev/dri/renderD128
local myeconfargs=(
@@ -185,7 +179,6 @@ src_configure() {
$(use_with openmp)
$(use_with opencl)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
- $(use_with X wxwidgets "${WX_CONFIG}")
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
$(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
$(use_with X x)
@@ -258,8 +251,7 @@ os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
-i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
if use X; then
- local GUI="-gui"
- [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ local GUI="--gui"
make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
doicon -s 48 gui/icons/${PN}-48x48.png
fi
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 1746efefa7c6..f104afc0e3a8 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -5,9 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
-WX_GTK_VER="3.0-gtk3"
-inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -149,11 +148,6 @@ src_prepare() {
}
src_configure() {
- if use X; then
- local WX_BUILD=yes
- setup-wxwidgets
- fi
-
addwrite /dev/dri/renderD128
local myeconfargs=(
@@ -187,7 +181,6 @@ src_configure() {
$(use_with opencl)
$(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
- $(use_with X wxwidgets "${WX_CONFIG}")
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
$(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
$(use_with X x)
@@ -260,8 +253,7 @@ os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
-i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
if use X; then
- local GUI="-gui"
- [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ local GUI="--gui"
make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
doicon -s 48 gui/icons/${PN}-48x48.png
fi