summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/massxpert
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/massxpert')
-rw-r--r--sci-chemistry/massxpert/Manifest2
-rw-r--r--sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch84
-rw-r--r--sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch91
-rw-r--r--sci-chemistry/massxpert/massxpert-2.0.5.ebuild56
-rw-r--r--sci-chemistry/massxpert/massxpert-3.4.0.ebuild56
-rw-r--r--sci-chemistry/massxpert/metadata.xml12
6 files changed, 301 insertions, 0 deletions
diff --git a/sci-chemistry/massxpert/Manifest b/sci-chemistry/massxpert/Manifest
new file mode 100644
index 000000000000..2288ccad80f4
--- /dev/null
+++ b/sci-chemistry/massxpert/Manifest
@@ -0,0 +1,2 @@
+DIST massxpert-2.0.5.tar.gz 13603475 SHA256 11f7f1599a587be923ed0b58e753e1f9296e0c3c0acfb5e3980579e768600e5c SHA512 49c1d8fa4324907d04c79dddad66eecae34ba1dded98594838b4cbb88ad022abe3f8fbd7f2aeee73baafc17a03397b1776f2e6fdabf4e2ac4e4f6d6eeb86ca2f WHIRLPOOL dba641144835d303eaf181a70aabee11dc14a43c8fe508ad33eb2ffe3c1c8a11eaa1ae066a8e9134e9d6c891cea5fc2dba503ca5e53acf62eb8b532d52c1bf3e
+DIST massxpert-3.4.0.tar.bz2 16544044 SHA256 b06314722b4cbdf68dc76e55933a79487848c655fc65341a8dbc707ed89cc9e8 SHA512 50e8eaab145ab7fa225725b113d6840168b88db7d2ee194b176bc88eabf4f44c20f8dc0680986d659de1f94f2e0c6ae10d54e17e2d8b3b5aa6a9a9bf57a508de WHIRLPOOL 4578801c2dd4eee7390eadb299f3d55af29d0a48365f96ba6d6488a07792e47882e191f8eda05b6b261d9a972bf7f92f160d4a5fbbcc216ed7ffda32fcfee6ed
diff --git a/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch b/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..63cbe2340008
--- /dev/null
+++ b/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch
@@ -0,0 +1,84 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8085e0a..eaae8ce 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,10 +23,10 @@ SET (CMAKE_VERBOSE_MAKEFILE ON)
+
+ #############################################################
+ # Enable warnings and treat them as errors
+-SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall -Werror.")
++SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall.")
+
+ IF (PEDANTIC)
+- ADD_DEFINITIONS (-Wall -Werror)
++ ADD_DEFINITIONS (-Wall)
+ ENDIF (PEDANTIC)
+
+ #############################################################
+@@ -51,9 +51,9 @@ ENDIF (WIN32)
+ IF (UNIX AND NOT APPLE)
+ SET (MASSXPERT_BIN_DIR ${CMAKE_INSTALL_PREFIX}/bin)
+ SET (MASSXPERT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert)
+- SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib/massxpert/plugins)
++ SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/massxpert/plugins)
+ SET (MASSXPERT_LOCALE_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert/locales)
+- SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert)
++ SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert-${VERSION})
+ SET (MASSXPERT_USERMAN_DIR ${MASSXPERT_DOC_DIR}/usermanual)
+ ENDIF (UNIX AND NOT APPLE)
+
+@@ -122,10 +122,6 @@ IF (${BUILD_PROGRAM})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The desktop file
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert.desktop
+@@ -165,10 +161,6 @@ IF (${BUILD_DATA})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (data)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-data.7
+@@ -201,10 +193,6 @@ IF (${BUILD_USERMANUAL})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (user manual)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-doc.7
+diff --git a/gui/configurationSettingsDlg.cpp b/gui/configurationSettingsDlg.cpp
+index bf595d5..82cad21 100644
+--- a/gui/configurationSettingsDlg.cpp
++++ b/gui/configurationSettingsDlg.cpp
+@@ -309,13 +309,11 @@ namespace massXpert
+ bool
+ ConfigurationSettingsDlg::checkLocalizationDir(const QDir &dir)
+ {
+- // At the moment there is the french translation: massxpert_fr.qm
++ // Gentoo provides optional installing of translations.
++ // If you decide not to have translations, then this check
++ // would fail.
+
+- QString filePath(dir.absolutePath() +
+- QDir::separator() +
+- "massxpert_fr.qm");
+-
+- return QFile::exists(filePath);
++ return true;
+ }
+
+
diff --git a/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch b/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch
new file mode 100644
index 000000000000..fc0fc4f606cf
--- /dev/null
+++ b/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch
@@ -0,0 +1,91 @@
+ CMakeLists.txt | 20 ++++----------------
+ gui/configurationSettingsDlg.cpp | 10 ++++------
+ 2 files changed, 8 insertions(+), 22 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fec954b..b87d157 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,10 +24,10 @@ SET (CMAKE_VERBOSE_MAKEFILE ON)
+ #############################################################
+ # Enable warnings and treat them as errors, on GNU/Linux only
+ IF (UNIX)
+- SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall -Werror.")
++ SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall.")
+
+ IF (PEDANTIC)
+- ADD_DEFINITIONS (-Wall -Werror)
++ ADD_DEFINITIONS (-Wall)
+ ENDIF (PEDANTIC)
+ ENDIF (UNIX)
+
+@@ -64,12 +64,12 @@ IF (UNIX AND NOT APPLE)
+ # Plugin-specific stuff, some distros set CMAKE_INSTALL_LIBDIR to
+ # /usr/lib64 (Fedora64, for example)
+ IF (NOT CMAKE_INSTALL_LIBDIR)
+- SET (CMAKE_INSTALL_LIBDIR ${CMAKE_INSTALL_PREFIX}/lib)
++ SET (CMAKE_INSTALL_LIBDIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ ENDIF (NOT CMAKE_INSTALL_LIBDIR)
+ SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_LIBDIR}/massxpert/plugins)
+
+ SET (MASSXPERT_LOCALE_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert/locales)
+- SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert)
++ SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert-${VERSION})
+ SET (MASSXPERT_USERMAN_DIR ${MASSXPERT_DOC_DIR}/usermanual)
+ ENDIF (UNIX AND NOT APPLE)
+
+@@ -144,10 +144,6 @@ IF (${BUILD_PROGRAM})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The desktop file
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert.desktop
+@@ -185,10 +181,6 @@ IF (${BUILD_DATA})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (data)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-data.7
+@@ -219,10 +211,6 @@ IF (${BUILD_USERMANUAL})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (user manual)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-doc.7
+diff --git a/gui/configurationSettingsDlg.cpp b/gui/configurationSettingsDlg.cpp
+index bf595d5..82cad21 100644
+--- a/gui/configurationSettingsDlg.cpp
++++ b/gui/configurationSettingsDlg.cpp
+@@ -309,13 +309,11 @@ namespace massXpert
+ bool
+ ConfigurationSettingsDlg::checkLocalizationDir(const QDir &dir)
+ {
+- // At the moment there is the french translation: massxpert_fr.qm
++ // Gentoo provides optional installing of translations.
++ // If you decide not to have translations, then this check
++ // would fail.
+
+- QString filePath(dir.absolutePath() +
+- QDir::separator() +
+- "massxpert_fr.qm");
+-
+- return QFile::exists(filePath);
++ return true;
+ }
+
+
diff --git a/sci-chemistry/massxpert/massxpert-2.0.5.ebuild b/sci-chemistry/massxpert/massxpert-2.0.5.ebuild
new file mode 100644
index 000000000000..ba0ee2dd9491
--- /dev/null
+++ b/sci-chemistry/massxpert/massxpert-2.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="A software suite to predict/analyze mass spectrometric data on (bio)polymers"
+HOMEPAGE="http://massxpert.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/source/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-qt/qtsvg:4[debug?]"
+DEPEND="${DEPEND}
+ doc? ( virtual/latex-base )"
+
+MASSXPERT_LANGS="fr"
+
+for L in ${MASSXPERT_LANGS}; do
+ IUSE="${IUSE} linguas_${L}"
+done
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ local langs=
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} ${MASSXPERT_LANGS}; then
+ langs="${langs} ${PN}_${lingua}.qm"
+ fi
+ done
+
+ sed -i -e "s/\(SET (massxpert_TRANSLATIONS \).*/\1${langs})/" \
+ gui/CMakeLists.txt || die "setting up translations failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PROGRAM=1
+ -DBUILD_DATA=1
+ )
+ use doc && mycmakeargs+=( -DBUILD_USERMANUAL=1 )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon "gui/images/${PN}-icon-32.xpm" || die "installing icon failed"
+ dodoc TODO || die "dodoc failed"
+}
diff --git a/sci-chemistry/massxpert/massxpert-3.4.0.ebuild b/sci-chemistry/massxpert/massxpert-3.4.0.ebuild
new file mode 100644
index 000000000000..b9aa2467f5d6
--- /dev/null
+++ b/sci-chemistry/massxpert/massxpert-3.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Software suite to predict/analyze mass spectrometric data on (bio)polymers"
+HOMEPAGE="http://massxpert.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/source/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-qt/qtsvg:4[debug?]"
+DEPEND="${DEPEND}
+ doc? ( virtual/latex-base )"
+
+MASSXPERT_LANGS="fr"
+
+for L in ${MASSXPERT_LANGS}; do
+ IUSE="${IUSE} linguas_${L}"
+done
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ local langs=
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} ${MASSXPERT_LANGS}; then
+ langs="${langs} ${PN}_${lingua}.qm"
+ fi
+ done
+
+ sed -i -e "s/\(SET (massxpert_TRANSLATIONS \).*/\1${langs})/" \
+ gui/CMakeLists.txt || die "setting up translations failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PROGRAM=1
+ -DBUILD_DATA=1
+ )
+ use doc && mycmakeargs+=( -DBUILD_USERMANUAL=1 )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon "gui/images/${PN}-icon-32.xpm"
+ dodoc TODO
+}
diff --git a/sci-chemistry/massxpert/metadata.xml b/sci-chemistry/massxpert/metadata.xml
new file mode 100644
index 000000000000..a4137981114b
--- /dev/null
+++ b/sci-chemistry/massxpert/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
+Prediction and analysis of mass spectrometric data for proteomic projects.
+</longdescription>
+</pkgmetadata>