summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 18:55:52 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:27:30 +0200
commit56f262a80942b70e39a59e723fd7091db3a5dc80 (patch)
tree42d7b91f4f81627f1056e888182405b75005bacc /sci-chemistry/chemex/chemex-0.6.1.ebuild
parentx11-themes/ubuntu-wallpapers: Drop old (diff)
downloadgentoo-56f262a80942b70e39a59e723fd7091db3a5dc80.tar.gz
gentoo-56f262a80942b70e39a59e723fd7091db3a5dc80.tar.bz2
gentoo-56f262a80942b70e39a59e723fd7091db3a5dc80.zip
sci-chemistry/chemex: Introduce chemex
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sci-chemistry/chemex/chemex-0.6.1.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-0.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-0.6.1.ebuild b/sci-chemistry/chemex/chemex-0.6.1.ebuild
new file mode 100644
index 000000000000..28af7461892f
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/matplotlib-1.1[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.11[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ # Fix quotes to detect the version properly
+ sed -i -e 's/matplotlib>=1.3.1/matplotlib>="1.3.1"/' setup.py || die
+ distutils-r1_python_prepare_all
+}