summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-10-23 20:18:05 +0100
committerDavid Seifert <soap@gentoo.org>2022-10-23 20:18:05 +0100
commitfb20e3f85e6e158e7f3a13b5de473ccaba372a03 (patch)
treee38911372e96bcdec18282d685d0a9feae6e48ef /sci-biology
parentdev-python/kombu: add 5.3.0_beta2 (diff)
downloadgentoo-fb20e3f85e6e158e7f3a13b5de473ccaba372a03.tar.gz
gentoo-fb20e3f85e6e158e7f3a13b5de473ccaba372a03.tar.bz2
gentoo-fb20e3f85e6e158e7f3a13b5de473ccaba372a03.zip
sci-biology/eugene: fix clang 16 build
Closes: https://bugs.gentoo.org/875476 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/eugene/eugene-4.1d-r1.ebuild1
-rw-r--r--sci-biology/eugene/files/eugene-4.1d-clang16.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/sci-biology/eugene/eugene-4.1d-r1.ebuild b/sci-biology/eugene/eugene-4.1d-r1.ebuild
index b1d9f409c096..40fb83ffc058 100644
--- a/sci-biology/eugene/eugene-4.1d-r1.ebuild
+++ b/sci-biology/eugene/eugene-4.1d-r1.ebuild
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.1d-fix-c++14.patch
"${FILESDIR}"/${PN}-4.1d-Wformat.patch
"${FILESDIR}"/${PN}-4.1d-portable-getopt.patch
+ "${FILESDIR}"/${PN}-4.1d-clang16.patch
)
src_prepare() {
diff --git a/sci-biology/eugene/files/eugene-4.1d-clang16.patch b/sci-biology/eugene/files/eugene-4.1d-clang16.patch
new file mode 100644
index 000000000000..21a3ec0a8b62
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-4.1d-clang16.patch
@@ -0,0 +1,22 @@
+--- a/src/GDIF/gdIF.c
++++ b/src/GDIF/gdIF.c
+@@ -228,7 +228,7 @@
+ ToY(phase, pos), (unsigned char *)st, Col[col]);
+ }
+
+-void ClosePNG()
++void ClosePNG(void)
+ {
+ int i;
+
+--- a/src/SensorPlugins/0_SensorTk/markov.cc
++++ b/src/SensorPlugins/0_SensorTk/markov.cc
+@@ -790,7 +790,7 @@
+ // cumule les valeurs des cases des codons synonymes et renvoie le total.
+ template<class CHAINE, typename T> T TabChaine<CHAINE,T> :: cumuleVAL (int indice) const
+ {
+- char* codegenetique=CODEGENETIQUE;
++ const char* codegenetique=CODEGENETIQUE;
+ T cumul=0;
+ for (int i=0 ; i<64 ; i++) {
+ if ( codegenetique[i] == codegenetique[indice] )