summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-27 11:03:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-27 11:03:11 +0200
commitf7c4faf8a3a9f03a09b4a5d6aac39b0ecc8a720c (patch)
treefa431630335d9df9f13a8a175564ca68f6ea2fa2 /sci-astronomy
parentsci-astronomy/wcslib: workaround collision with sci-astronomy/montage (diff)
downloadgentoo-f7c4faf8a3a9f03a09b4a5d6aac39b0ecc8a720c.tar.gz
gentoo-f7c4faf8a3a9f03a09b4a5d6aac39b0ecc8a720c.tar.bz2
gentoo-f7c4faf8a3a9f03a09b4a5d6aac39b0ecc8a720c.zip
sci-astronomy/wcslib: drop 8.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/wcslib-8.3.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sci-astronomy/wcslib/wcslib-8.3.ebuild b/sci-astronomy/wcslib/wcslib-8.3.ebuild
deleted file mode 100644
index 942d8b59a872..000000000000
--- a/sci-astronomy/wcslib/wcslib-8.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_NEEDED=fortran
-
-inherit flag-o-matic fortran-2
-
-DESCRIPTION="Astronomical World Coordinate System transformations library"
-HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
-SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
-
-SLOT="0/$(ver_cut 1)"
-LICENSE="LGPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc fortran fits pgplot static-libs +tools"
-
-RDEPEND="
- fits? ( sci-libs/cfitsio:0= )
- pgplot? ( sci-libs/pgplot:0= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-alternatives/lex
- virtual/pkgconfig"
-
-src_configure() {
- # workaround until upstream fix it properly
- append-fflags $(test-flags-FC -fallow-argument-mismatch)
-
- local myconf=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}
- $(use_enable fortran)
- $(use_enable tools utils)
- --with-bindc
- )
- # hacks because cfitsio and pgplot directories are hard-coded
- if use fits; then
- myconf+=(
- --with-cfitsioinc="${EPREFIX}/usr/include"
- --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-cfitsio )
- fi
- if use pgplot; then
- myconf+=(
- --with-pgplotinc="${EPREFIX}/usr/include"
- --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-pgplot )
- fi
- econf "${myconf[@]}"
- sed -i -e 's/COPYING\*//' GNUmakefile || die
-}
-
-src_install () {
- default
- # static libs share the same symbols as shared (i.e. compiled with PIC)
- # so they are not compiled twice
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/lib*.a || die
- fi
-
- if ! use doc; then
- rm -r \
- "${ED}"/usr/share/doc/${PF}/html \
- "${ED}"/usr/share/doc/${PF}/*.pdf || die
- fi
- # always creates this symlink
- rm "${ED}"/usr/share/doc/${PN} || die
-}