summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-02-19 08:46:32 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2024-02-19 08:46:32 +0100
commit791ab23aa4c758477325aea93f376a89e289eb5b (patch)
treeae5f9aff3f11fc484b4b10d5b98b6483c757e517 /net-wireless
parentdev-embedded/u-boot-tools: Fix missing BDEPENDs (diff)
downloadgentoo-791ab23aa4c758477325aea93f376a89e289eb5b.tar.gz
gentoo-791ab23aa4c758477325aea93f376a89e289eb5b.tar.bz2
gentoo-791ab23aa4c758477325aea93f376a89e289eb5b.zip
net-wireless/soapyplutosdr: add 0.2.2
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/soapyplutosdr/Manifest1
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild27
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild4
3 files changed, 30 insertions, 2 deletions
diff --git a/net-wireless/soapyplutosdr/Manifest b/net-wireless/soapyplutosdr/Manifest
index 12cf45f42a62..73b6c739b281 100644
--- a/net-wireless/soapyplutosdr/Manifest
+++ b/net-wireless/soapyplutosdr/Manifest
@@ -1,2 +1,3 @@
DIST soapyplutosdr-0.2.1.tar.gz 17597 BLAKE2B d5b6205da7aa64406ccf84d198088094c10397ca874925926dfe2ee3134e045c3ab80b68db06ee84448ae8966e2d8edecb2517ef70b10bbddd9681fcbf09385a SHA512 40cc7c83c13f1d81212c5b0b6028d49de6c9e0b4df9e479c5cb577f60a92b415f76e159d45ecf19aad2deac507f7bd779b7cce1f7bc5e6fd2ea9a3f24399dfe7
DIST soapyplutosdr-0.2.1_p20220710.tar.gz 25233 BLAKE2B b7151f6a00f820edf958006c6ece78e75ad0f5b5b07a232d82dbbf8cf86fa414eed085ee769ecf66fb707dac5d006925791dfd39c1a7fc35f8f887543fe0daf3 SHA512 55757db81d715466148c8376d713783af85ce072036d97ea80b5bd1993fa2180f2f8ca20391d83d1fc5cb6a2ff9977f34d95ddc2beff9ed21282af40b47ea160
+DIST soapyplutosdr-0.2.2.tar.gz 25472 BLAKE2B 100b366edf268c76109be2d335b6d4d6a5723a219f1f160d481385e7ac7c89e3cd25860e9916b754f67708f83d90e6f82262572c6a62eb045483a2bba6a794b3 SHA512 dd5514cde4867bd915b2ef1f0257af85359986b93a7650f00f665fd83a7d7a2c8621f79fe91ce1c16867fdff0c0c14b700628cd9a94746c11b854da1afd7daf7
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild
new file mode 100644
index 000000000000..115e42eb16c6
--- /dev/null
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugin for the Pluto SDR"
+HOMEPAGE="https://github.com/pothosware/SoapyPlutoSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ COMMIT="422a9b306f765499dd3e9a4c3400fa39816dcfdb"
+ SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-libs/libiio:=
+ net-libs/libad9361-iio:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
index 254e0ba2adb5..115e42eb16c6 100644
--- a/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
else
KEYWORDS="~amd64 ~arm ~riscv ~x86"
- COMMIT="b906b27e6820fe44fcc3527cc876771f7dac85d2"
+ COMMIT="422a9b306f765499dd3e9a4c3400fa39816dcfdb"
SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
fi