summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/hostap-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/hostap-utils')
-rw-r--r--net-wireless/hostap-utils/Manifest1
-rw-r--r--net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch31
-rw-r--r--net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild34
-rw-r--r--net-wireless/hostap-utils/metadata.xml6
4 files changed, 72 insertions, 0 deletions
diff --git a/net-wireless/hostap-utils/Manifest b/net-wireless/hostap-utils/Manifest
new file mode 100644
index 000000000000..bba788616c6e
--- /dev/null
+++ b/net-wireless/hostap-utils/Manifest
@@ -0,0 +1 @@
+DIST hostap-utils-0.4.7.tar.gz 60782 SHA256 c6f598d8e356c1620fa009eca0a700bf1105e16817eefd77d891994261009355 SHA512 1a54c5d84b02d2dc96c33d6463af775212e09a20ac85367184636d364f17a09e48f937417dd9c43148663d242b3fc5f2f13835ec5331bd0600ef31797c414d44 WHIRLPOOL 4e195921144640806d944ce2628dbd15fa1cf8c3b51d5ba761476fa5fc301478bca1b99f3f8cf401d3854492f4e8ed1ee9449469722b9f9030c1269cf63d1450
diff --git a/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch b/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch
new file mode 100644
index 000000000000..366a878b7b62
--- /dev/null
+++ b/net-wireless/hostap-utils/files/hostap-utils-0.4.7-makefile.patch
@@ -0,0 +1,31 @@
+--- Makefile.orig 2012-11-20 12:16:39.747881769 +0400
++++ Makefile 2012-11-20 12:17:39.248881307 +0400
+@@ -1,7 +1,3 @@
+-ifndef CFLAGS
+-CFLAGS = -O2 -Wall
+-endif
+-
+ # Include directory for CVS version
+ CFLAGS += -I../driver/modules
+
+@@ -14,17 +10,17 @@
+ hostap_crypt_conf: hostap_crypt_conf.c
+
+ hostap_diag: hostap_diag.o util.o
+- $(CC) -o hostap_diag $(CFLAGS) hostap_diag.o util.o
++ $(CC) -o hostap_diag $(CFLAGS) $(LDFLAGS) hostap_diag.o util.o
+
+ hostap_diag.o: hostap_diag.c util.h
+
+ util.o: util.c util.h
+
+ hostap_io_debug: hostap_io_debug.c
+- $(CC) -o hostap_io_debug $(CFLAGS) hostap_io_debug.c
++ $(CC) -o hostap_io_debug $(CFLAGS) $(LDFLAGS) hostap_io_debug.c
+
+ hostap_rid: hostap_rid.o util.o
+- $(CC) -o hostap_rid $(CFLAGS) hostap_rid.o util.o
++ $(CC) -o hostap_rid $(CFLAGS) $(LDFLAGS) hostap_rid.o util.o
+
+ hostap_rid.o: hostap_rid.c util.h
+
diff --git a/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild b/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..9586f3b52886
--- /dev/null
+++ b/net-wireless/hostap-utils/hostap-utils-0.4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Utilities for Intersil Prism2/2.5/3 based IEEE 802.11b wireless LAN products"
+HOMEPAGE="http://hostap.epitest.fi/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin hostap_{crypt_conf,diag,fw_load,io_debug,rid}
+ dosbin prism2_{param,srec}
+ dosbin split_combined_hex
+
+ dodoc README
+}
diff --git a/net-wireless/hostap-utils/metadata.xml b/net-wireless/hostap-utils/metadata.xml
new file mode 100644
index 000000000000..c078bde811ae
--- /dev/null
+++ b/net-wireless/hostap-utils/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<longdescription>Utility programs for hostap-driver</longdescription>
+</pkgmetadata>