summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-02-10 00:12:20 +0200
committerMart Raudsepp <leio@gentoo.org>2024-02-10 00:25:32 +0200
commit492df622c79fb87939fb19b547103cb8bec06f56 (patch)
treeb4b3b66e74eb5c14b96f0b484605b0f0e231e013 /net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild
parentgames-arcade/gnome-nibbles: add 4.0.2 (diff)
downloadgentoo-492df622c79fb87939fb19b547103cb8bec06f56.tar.gz
gentoo-492df622c79fb87939fb19b547103cb8bec06f56.tar.bz2
gentoo-492df622c79fb87939fb19b547103cb8bec06f56.zip
net-wireless/gnome-bluetooth: add 42.8
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild
new file mode 100644
index 000000000000..c09f8f7bf93a
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-42.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="3/13" # subslot = libgnome-bluetooth-3 soname version
+IUSE="gtk-doc +introspection sendto test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.4:4[introspection?]
+ media-libs/gsound
+ >=gui-libs/libadwaita-1.1:1
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev:=
+ >=sys-power/upower-0.99.14:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+ sendto? ( !net-wireless/gnome-bluetooth:2 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version ">=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ # Check for python is unconditional
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use sendto)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Workaround test failures caused by flatpak being installed that adds to XDG_DATA_DIRS
+ gnome_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+
+ meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}