summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKan Yan <kyan@google.com>2018-01-09 15:04:07 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-09 15:10:35 -0500
commitf0ef8838240c82dd67689b80bbb45d4c3d490296 (patch)
tree093f1c4897b57604d449940ac65e690f54f2063f /net-proxy
parentMask attr-2.4.48 for bug 644049 (diff)
downloadgentoo-f0ef8838240c82dd67689b80bbb45d4c3d490296.tar.gz
gentoo-f0ef8838240c82dd67689b80bbb45d4c3d490296.tar.bz2
gentoo-f0ef8838240c82dd67689b80bbb45d4c3d490296.zip
net-proxy/squid: fix cross-compiling
Current versions of squid have a run test for gnu atomics w/no cross-compile fallback causing builds to fail. Upstream has rewritten this completely, so until we update to a newer version, force the cache variable when cross-compiling. Forcing it to no might not be optimal in all cases, but it's better than nothing. We have been turning on large-file-system support for a while now, but the configure test for that probes the build system for flags to compile with (via `getconf ...`). These flags don't work for the cross-compile target, and in reality are rarely necessary. By selecting the default, we always go the standard POSIX route with the -D_FILE_OFFSET_BITS=64 flag. If a target doesn't respect that flag, then it might fail to build, but we can wait for anyone to complain.
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squid/squid-3.5.27.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-proxy/squid/squid-3.5.27.ebuild b/net-proxy/squid/squid-3.5.27.ebuild
index 97b9d9c2897a..5ccd7f6f458d 100644
--- a/net-proxy/squid/squid-3.5.27.ebuild
+++ b/net-proxy/squid/squid-3.5.27.ebuild
@@ -158,6 +158,10 @@ src_configure() {
export BUILDCXXFLAGS=${BUILD_CXXFLAGS}
tc-export CC AR
+ # Should be able to drop this workaround with newer versions.
+ # https://bugs.squid-cache.org/show_bug.cgi?id=4224
+ tc-is-cross-compiler && export squid_cv_gnu_atomics=no
+
econf \
--sysconfdir=/etc/squid \
--libexecdir=/usr/libexec/squid \
@@ -182,6 +186,7 @@ src_configure() {
--enable-icmp \
--enable-follow-x-forwarded-for \
--with-large-files \
+ --with-build-environment=default \
--disable-strict-error-checking \
--disable-arch-native \
--with-ltdl-includedir=/usr/include \