summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/webscarab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/webscarab')
-rw-r--r--net-proxy/webscarab/Manifest1
-rw-r--r--net-proxy/webscarab/files/webscarab.sh3
-rw-r--r--net-proxy/webscarab/metadata.xml14
-rw-r--r--net-proxy/webscarab/webscarab-20070504.ebuild26
4 files changed, 44 insertions, 0 deletions
diff --git a/net-proxy/webscarab/Manifest b/net-proxy/webscarab/Manifest
new file mode 100644
index 000000000000..0046b0db706e
--- /dev/null
+++ b/net-proxy/webscarab/Manifest
@@ -0,0 +1 @@
+DIST webscarab-selfcontained-20070504-1631.jar 3024410 SHA256 dd76a05452e5b8d2b78500715851610ae5f320724cc41f79e28f1808e19df509
diff --git a/net-proxy/webscarab/files/webscarab.sh b/net-proxy/webscarab/files/webscarab.sh
new file mode 100644
index 000000000000..f056097623f9
--- /dev/null
+++ b/net-proxy/webscarab/files/webscarab.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec java -jar /usr/lib/webscarab.jar
diff --git a/net-proxy/webscarab/metadata.xml b/net-proxy/webscarab/metadata.xml
new file mode 100644
index 000000000000..062081473866
--- /dev/null
+++ b/net-proxy/webscarab/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>WebScarab is designed to be a tool for anyone who needs to expose the workings
+of an HTTP(S) based application, whether to allow the developer to debug otherwise difficult problems
+or to allow a security specialist to identify vulnerabilities in the way that the application has been
+designed or implemented.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">owasp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-proxy/webscarab/webscarab-20070504.ebuild b/net-proxy/webscarab/webscarab-20070504.ebuild
new file mode 100644
index 000000000000..9b94106f456b
--- /dev/null
+++ b/net-proxy/webscarab/webscarab-20070504.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib
+
+DESCRIPTION="A framework for analysing applications that communicate using the HTTP and HTTPS protocols"
+HOMEPAGE="https://www.owasp.org/index.php/Webscarab"
+SRC_URI="mirror://sourceforge/owasp/${PN}-selfcontained-${PV}-1631.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+
+src_unpack() {
+ : # Nothing to unpack
+}
+
+src_install() {
+ newbin "${FILESDIR}/${PN}.sh" "${PN}" || die "dobin failed"
+ insinto /usr/$(get_libdir)
+ newins "${DISTDIR}/${A}" "${PN}.jar" || die "failed to install jar archive"
+}