summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-17 16:11:23 +0100
committerSam James <sam@gentoo.org>2023-02-19 19:55:49 +0000
commit6377b4c91315f0b5e1da1177e347627b8033852b (patch)
tree0a138528e65dfd16ff295cac555b1caca81dc2f0 /net-proxy/haproxy/haproxy-2.4.22.ebuild
parentsci-calculators/bc-gh: bump to 6.2.6 (diff)
downloadgentoo-6377b4c91315f0b5e1da1177e347627b8033852b.tar.gz
gentoo-6377b4c91315f0b5e1da1177e347627b8033852b.tar.bz2
gentoo-6377b4c91315f0b5e1da1177e347627b8033852b.zip
net-proxy/haproxy: fix musl support in all available versions
TARGET needs to be set to linux-musl for proper musl support. It is available since version 2.2, therefore all currently present ebuilds are updated appropriately. Closes: https://bugs.gentoo.org/866053 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29637 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.4.22.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.4.22.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-proxy/haproxy/haproxy-2.4.22.ebuild b/net-proxy/haproxy/haproxy-2.4.22.ebuild
index 1dc2f69b3bad..a4d1fb37c08b 100644
--- a/net-proxy/haproxy/haproxy-2.4.22.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.22.ebuild
@@ -71,12 +71,17 @@ pkg_setup() {
src_compile() {
local -a args=(
V=1
- TARGET=linux-glibc
# Switching to PCRE2 by default, bug 838013
PCRE=
PCRE_JIT=
)
+ if use elibc_musl; then
+ args+=( TARGET=linux-musl )
+ else
+ args+=( TARGET=linux-glibc )
+ fi
+
# TODO: PCRE2_WIDTH?
args+=( $(haproxy_use threads THREAD) )
args+=( $(haproxy_use crypt LIBCRYPT) )