summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:42 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:42 +0100
commite8d4ed31be16749a658b2442b05019a1431fd06a (patch)
treec1c0dbaaa6a7847e925534fe84b565f06da19be1 /net-p2p
parentnet-p2p/resilio-sync: add libcrypt compat dependency (diff)
downloadgentoo-e8d4ed31be16749a658b2442b05019a1431fd06a.tar.gz
gentoo-e8d4ed31be16749a658b2442b05019a1431fd06a.tar.bz2
gentoo-e8d4ed31be16749a658b2442b05019a1431fd06a.zip
net-p2p/opendchub: add missing libcrypt dependency, fix other deps
* Add missing virtual/libcrypt:= dependency * Add missing OpenSSL dependency * We link against libperl => subslot operator on dev-lang/perl * When USE=-perl, we link against libcap, so add dependency Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/opendchub/opendchub-0.8.2-r1.ebuild (renamed from net-p2p/opendchub/opendchub-0.8.2.ebuild)11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-p2p/opendchub/opendchub-0.8.2.ebuild b/net-p2p/opendchub/opendchub-0.8.2-r1.ebuild
index 047e913aefc7..36f50391ce0d 100644
--- a/net-p2p/opendchub/opendchub-0.8.2.ebuild
+++ b/net-p2p/opendchub/opendchub-0.8.2-r1.ebuild
@@ -14,13 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc x86"
IUSE="perl"
-RDEPEND="perl? ( dev-lang/perl )"
+RDEPEND="dev-libs/openssl:=
+ virtual/libcrypt:=
+ perl? ( dev-lang/perl:= )
+ !perl? ( sys-libs/libcap )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-telnet.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-telnet.patch
+)
src_prepare() {
default
+
eautoreconf
}
@@ -32,6 +38,7 @@ src_configure() {
src_install() {
default
+
dodoc -r Documentation/.
if use perl; then