summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <droman@ifae.es>2024-09-12 11:47:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-10-17 10:30:41 +0300
commit530db9298b6b8b64fbae523dc74236863bf94cd0 (patch)
tree0bc69e36918d353f2cff26c45b7b1c003c9b0429 /net-p2p
parentnet-p2p/kubo: drop 0.26.0, 0.29.0 (diff)
downloadgentoo-530db9298b6b8b64fbae523dc74236863bf94cd0.tar.gz
gentoo-530db9298b6b8b64fbae523dc74236863bf94cd0.tar.bz2
gentoo-530db9298b6b8b64fbae523dc74236863bf94cd0.zip
net-p2p/kubo: add 0.30.0
Signed-off-by: David Roman <droman@ifae.es> Closes: https://github.com/gentoo/gentoo/pull/38575 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kubo/Manifest3
-rw-r--r--net-p2p/kubo/kubo-0.30.0.ebuild90
2 files changed, 93 insertions, 0 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index 06139a876d58..f834e166bdc3 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -2,3 +2,6 @@ DIST kubo-0.28.0.tar.gz 16070929 BLAKE2B f0febdee1e2313c83369c07b520fe285e10a733
DIST kubo-0.29.0-fs-repo-15-to-16-v1.0.1-vendor.tar.xz 1643384 BLAKE2B 6c51d34ab06e662213075cdc73fce0d3dad8c9acbfd2af6cd68ee50e90c33b91f06a68bbe40f4f3de867dd2862fb3cc0a09cb377f4d1ae70750906236059de5d SHA512 f3d9fbfc93fa714491eb7b8c995b686b8af86a65c56e7f14034b0dedb36b2b9a4d489852d7988acce30dcfd53f1637e1dca42ffdaa785bc6104864fc19c45a0c
DIST kubo-0.29.0-fs-repo-15-to-16-v1.0.1.tar.gz 25942003 BLAKE2B 48eb3f50c8d0064561a99dd834cfc73482003bed70be93342bb30e993b509cca6aea0d44658ea981bb1063c458ce98e796293172b01109265e431f7a6ae279ae SHA512 bf631d402ecbee75e5a49e19e31c40172aeef81a13325bbf557841ba9e765caf39df42370a20d6e4039e7bd98e27dc5bd7a42f4490f30928a5614aca2214aea1
DIST kubo-0.29.0.tar.gz 16229764 BLAKE2B 91a6d322987bf7316f4acaf984ea57ea69617925e56adf4cee06be4d08a3a77f8f197aed42aa16cd438485df657de02cd647d3319c7c1afd09c0b8410fab30e6 SHA512 f23496452c3382629fddafce039acdff51c085280b15b807923bc4474b3ec540a39f9906ba7dcba621fef6237336ee2eb1bed10f81cac7a1dfccb21b7c3fecfb
+DIST kubo-0.30.0-fs-repo-15-to-16-v1.0.1-vendor.tar.xz 1643384 BLAKE2B 6c51d34ab06e662213075cdc73fce0d3dad8c9acbfd2af6cd68ee50e90c33b91f06a68bbe40f4f3de867dd2862fb3cc0a09cb377f4d1ae70750906236059de5d SHA512 f3d9fbfc93fa714491eb7b8c995b686b8af86a65c56e7f14034b0dedb36b2b9a4d489852d7988acce30dcfd53f1637e1dca42ffdaa785bc6104864fc19c45a0c
+DIST kubo-0.30.0-fs-repo-15-to-16-v1.0.1.tar.gz 25942003 BLAKE2B 48eb3f50c8d0064561a99dd834cfc73482003bed70be93342bb30e993b509cca6aea0d44658ea981bb1063c458ce98e796293172b01109265e431f7a6ae279ae SHA512 bf631d402ecbee75e5a49e19e31c40172aeef81a13325bbf557841ba9e765caf39df42370a20d6e4039e7bd98e27dc5bd7a42f4490f30928a5614aca2214aea1
+DIST kubo-0.30.0.tar.gz 16532306 BLAKE2B 9241e8d463dfe0fd407fc6e2a30174ff67a63360a3dbef93d6f1b70fbe42ea9ce873e74109569964b8894adf95555c12b1ed66c50743b8eda591bf48b79fe8e7 SHA512 f49b53a51a07675d02d0c4457ca1a166a3db5565fc2a1659b88861c6a9ec1e94243a86115399df31069ad1f8e93b1acf14fe8b40dea63bfd3109105ad262cccc
diff --git a/net-p2p/kubo/kubo-0.30.0.ebuild b/net-p2p/kubo/kubo-0.30.0.ebuild
new file mode 100644
index 000000000000..4ace39faabc1
--- /dev/null
+++ b/net-p2p/kubo/kubo-0.30.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion systemd
+
+FS_MIG_V="1.0.1"
+FS_MIG_N="fs-repo-15-to-16"
+MY_FS_MIG="${FS_MIG_N}-v${FS_MIG_V}"
+FS_MIG_DIR="fs-repo-migrations-${MY_FS_MIG}"
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.tech https://github.com/ipfs/kubo/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/ipfs/fs-repo-migrations/archive/refs/tags/${FS_MIG_N}/v${FS_MIG_V}.tar.gz -> ${P}-${MY_FS_MIG}.tar.gz"
+SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${MY_FS_MIG}-vendor.tar.xz -> ${P}-${MY_FS_MIG}-vendor.tar.xz"
+
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+src_prepare() {
+ default
+
+ sed -i '/fs-repo-1[0-9]-to-*/d' "${FS_MIG_DIR}/ignored-migrations" || die
+}
+
+src_compile() {
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
+ ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+ IPFS_PATH="" ./ipfs commands completion fish > ipfs-completion.fish || die
+ IPFS_PATH="" ./ipfs commands completion zsh > ipfs-completion.zsh || die
+
+ cd "${FS_MIG_DIR}" || die
+ emake
+}
+
+src_test() {
+ ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ newfishcomp ipfs-completion.fish ipfs
+ newzshcomp ipfs-completion.zsh _ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+
+ find "${FS_MIG_DIR}" -executable -type f -name "fs-repo-*" -exec dobin {} \; || die
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case kubo CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}