summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-03-10 12:45:23 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-03-10 12:51:31 +1100
commit25253a5af117972cfb30dfc998b2f030554c0a3c (patch)
tree702e56def96d00174ab99397dda155d6b047ac50 /net-p2p/qbittorrent
parentnet-p2p/qbittorrent: add subslot operator (diff)
downloadgentoo-25253a5af117972cfb30dfc998b2f030554c0a3c.tar.gz
gentoo-25253a5af117972cfb30dfc998b2f030554c0a3c.tar.bz2
gentoo-25253a5af117972cfb30dfc998b2f030554c0a3c.zip
net-p2p/qbittorrent: version bump 4.0.4
Closes: https://bugs.gentoo.org/649914 Closes: https://bugs.gentoo.org/641382 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/files/qbittorrent-4.0.4-werror.patch24
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.0.4.ebuild65
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild10
4 files changed, 92 insertions, 8 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 776312a9a56b..e6dfe68d41d8 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,4 @@
DIST qbittorrent-3.3.16.tar.xz 2961420 BLAKE2B 3704e6575b1a321e04b0b9c1feee9acaf2e0ab5e0815c2cbb496265c8407c5b27111265e929ea3a516cba20acacc3b954579b5904de3411ae81726f2461dfbe0 SHA512 518ddbf8e657b3549800b5587924a8a34826895183f199b79aac72de81e6b5c009cb3b8d4fbb19151da0d96c21eb1c2f05d6ed061608cc8f589ec6fe62ce8117
DIST qbittorrent-4.0.1.tar.xz 4256588 BLAKE2B 579e850c34c62f515807a3fb2619740442c275e9de74cd7338a9e2d72340c78a2b7f484a3ee911094cbb3b551d61a927be454466637eac2d2355e84ebec0dbd4 SHA512 76eae32ebe82953e3164a8a292132a33ccc93f5a33ce7e1ce3253f4697939b73d21e1823bada7d3b1fe7401538a7f407ebeb86c281a34e261aec0aa02d7bef80
DIST qbittorrent-4.0.3.tar.xz 4274292 BLAKE2B c6f6a87d26f01db318ac021a8ab9f8d1ada2f7cb0d2819dfbd41e57ddbcda8a077161c78bcf8210e3571572872c13aa2255973e842c07b6b538d94ac2501c841 SHA512 d439e5428ff43ec9317bfa70b365a912a33fa12eeaad72c6916514e7b04509bf3d2e35ef9c07a36e42e7fc80f4e019f6a299fd2f93df9ec10af4a95257096ecd
+DIST qbittorrent-4.0.4.tar.xz 4279752 BLAKE2B 6385040d1179814e3290fb1c7b2d1e0b5782144663d12a067c43a2d8a47d0f0cfc0633c69f183db70eab2591ef100f39b07ea2d5e3cbca3a4d149ccb70e4d838 SHA512 ead0a306242d883673e13f9e6dc5ad83d4624c3d7ffb586aff78c03f7685e89b6a6c8640fff6a1b251565892178d37f4a64d45d0ce18935a212ca39302a28969
diff --git a/net-p2p/qbittorrent/files/qbittorrent-4.0.4-werror.patch b/net-p2p/qbittorrent/files/qbittorrent-4.0.4-werror.patch
new file mode 100644
index 000000000000..6d02e31f9bcb
--- /dev/null
+++ b/net-p2p/qbittorrent/files/qbittorrent-4.0.4-werror.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/641382
+
+--- a/cmake/Modules/MacroQbtCompilerSettings.cmake
++++ b/cmake/Modules/MacroQbtCompilerSettings.cmake
+@@ -11,16 +11,15 @@
+ #-Wshadow -Wconversion ?
+ set(_GCC_COMMON_C_AND_CXX_FLAGS "-Wall -Wextra"
+ "-Wfloat-equal -Wcast-qual -Wcast-align"
+- "-Wsign-conversion -Winvalid-pch -Werror=return-type -Wno-long-long"
++ "-Wsign-conversion -Winvalid-pch -Wno-long-long"
+ # -fstack-protector-all
+- "-Werror -Wno-error=deprecated-declarations"
++ "-Wno-error=deprecated-declarations"
+ )
+ set (_GCC_COMMON_CXX_FLAGS "-fexceptions -frtti"
+ "-Woverloaded-virtual -Wold-style-cast -Wstrict-null-sentinel"
+ "-Wnon-virtual-dtor -Wfloat-equal -Wcast-qual -Wcast-align"
+- "-Werror=overloaded-virtual"
+ # "-Weffc++"
+- "-Werror -Wno-error=cpp"
++ "-Wno-error=cpp"
+ # we should modify code to make these ones obsolete
+ "-Wno-error=sign-conversion -Wno-error=float-equal"
+ )
diff --git a/net-p2p/qbittorrent/qbittorrent-4.0.4.ebuild b/net-p2p/qbittorrent/qbittorrent-4.0.4.ebuild
new file mode 100644
index 000000000000..1f76cf096f6e
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.0.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ MY_P=${P/_}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+PATCHES=( "${FILESDIR}/${PN}-4.0.4-werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSTEM_QTSINGLEAPPLICATION=ON
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex X)
+ -DWEBUI=$(usex webui)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 21af49d18a48..1f76cf096f6e 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -29,7 +29,7 @@ RDEPEND="
dev-qt/qtnetwork:5[ssl]
>=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
dev-qt/qtxml:5
- >=net-libs/libtorrent-rasterbar-1.0.6:=
+ >=net-libs/libtorrent-rasterbar-1.0.6:0=
sys-libs/zlib
dbus? ( dev-qt/qtdbus:5 )
X? (
@@ -42,13 +42,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # bug 641382
- sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
-}
+PATCHES=( "${FILESDIR}/${PN}-4.0.4-werror.patch" )
src_configure() {
local mycmakeargs=(