summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-04-08 19:02:50 +0200
committerAaron Bauman <bman@gentoo.org>2018-04-08 20:08:36 -0400
commitd3e9868a04678b1a7f7cfc30156642e5dde81130 (patch)
treeff5bfadac439d146701df9008315dc989837b90c /net-p2p/bitcoin-qt/files
parentsci-visualization/opendx: remove unused patch (diff)
downloadgentoo-d3e9868a04678b1a7f7cfc30156642e5dde81130.tar.gz
gentoo-d3e9868a04678b1a7f7cfc30156642e5dde81130.tar.bz2
gentoo-d3e9868a04678b1a7f7cfc30156642e5dde81130.zip
net-p2p/bitcoin-qt: remove unused patch
Closes: https://github.com/gentoo/gentoo/pull/7878
Diffstat (limited to 'net-p2p/bitcoin-qt/files')
-rw-r--r--net-p2p/bitcoin-qt/files/0.13.2-libressl.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/net-p2p/bitcoin-qt/files/0.13.2-libressl.patch b/net-p2p/bitcoin-qt/files/0.13.2-libressl.patch
deleted file mode 100644
index 415adcc59eae..000000000000
--- a/net-p2p/bitcoin-qt/files/0.13.2-libressl.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-commit 0388afe69dd85ca9549727ee105ba7017169b464 (HEAD -> EVP_MD_CTX_new, personal-github/EVP_MD_CTX_new)
-Author: Luke Dashjr <luke-jr+git@utopios.org>
-Date: Wed Jan 4 17:07:42 2017 +0000
-
- Let autoconf detect presence of EVP_MD_CTX_new
-
- Fixes LibreSSL compatibility
-
-diff --git a/configure.ac b/configure.ac
-index ced258e..02af0d6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -832,6 +832,13 @@ else
- fi
- fi
-
-+save_CXXFLAGS="${CXXFLAGS}"
-+CXXFLAGS="${CXXFLAGS} ${CRYPTO_CFLAGS} ${SSL_CFLAGS}"
-+AC_CHECK_DECLS([EVP_MD_CTX_new],,,[AC_INCLUDES_DEFAULT
-+#include <openssl/x509_vfy.h>
-+])
-+CXXFLAGS="${save_CXXFLAGS}"
-+
- dnl univalue check
-
- need_bundled_univalue=yes
-diff --git a/src/qt/paymentrequestplus.cpp b/src/qt/paymentrequestplus.cpp
-index 82be4d8..0d4907b 100644
---- a/src/qt/paymentrequestplus.cpp
-+++ b/src/qt/paymentrequestplus.cpp
-@@ -159,7 +159,7 @@ bool PaymentRequestPlus::getMerchant(X509_STORE* certStore, QString& merchant) c
- std::string data_to_verify; // Everything but the signature
- rcopy.SerializeToString(&data_to_verify);
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if HAVE_DECL_EVP_MD_CTX_NEW
- EVP_MD_CTX *ctx = EVP_MD_CTX_new();
- if (!ctx) throw SSLVerifyError("Error allocating OpenSSL context.");
- #else
-@@ -174,7 +174,7 @@ bool PaymentRequestPlus::getMerchant(X509_STORE* certStore, QString& merchant) c
- !EVP_VerifyFinal(ctx, (const unsigned char*)paymentRequest.signature().data(), (unsigned int)paymentRequest.signature().size(), pubkey)) {
- throw SSLVerifyError("Bad signature, invalid payment request.");
- }
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if HAVE_DECL_EVP_MD_CTX_NEW
- EVP_MD_CTX_free(ctx);
- #endif
-