summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-28 11:27:46 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-28 11:29:03 +0300
commitb5aece8e7c84de10a3713e4588f1a20a1b62ad4a (patch)
tree44bc782ba2e85786c9cbbb2d139f22aba417b713 /net-nntp
parentnet-nntp/suck: Version bump, 4.3.4 (diff)
downloadgentoo-b5aece8e7c84de10a3713e4588f1a20a1b62ad4a.tar.gz
gentoo-b5aece8e7c84de10a3713e4588f1a20a1b62ad4a.tar.bz2
gentoo-b5aece8e7c84de10a3713e4588f1a20a1b62ad4a.zip
net-nntp/suck: tidy 4.3.4 ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/suck/suck-4.3.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-nntp/suck/suck-4.3.4.ebuild b/net-nntp/suck/suck-4.3.4.ebuild
index 6e3a5533c5c3..ecb5006bebe9 100644
--- a/net-nntp/suck/suck-4.3.4.ebuild
+++ b/net-nntp/suck/suck-4.3.4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
@@ -37,8 +38,13 @@ src_prepare() {
}
src_configure() {
- use ssl || sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
- use perl || sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+ if use ssl; then
+ sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
+ fi
+
+ if use perl; then
+ sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+ fi
econf --without-inn-lib --without-inn-include
}