summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-20 22:44:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-20 23:01:10 +0200
commitb78b9808ad65b91102af98730e6cb6a2c4369e05 (patch)
tree8ac4446d61efdaa4e3eaeb33a76352dc65df4258 /net-misc
parentnet-misc/unison: misc fixes (diff)
downloadgentoo-b78b9808ad65b91102af98730e6cb6a2c4369e05.tar.gz
gentoo-b78b9808ad65b91102af98730e6cb6a2c4369e05.tar.bz2
gentoo-b78b9808ad65b91102af98730e6cb6a2c4369e05.zip
net-misc/unison: bump to 2.53.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.53.5.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 120b6d85e835..3f10329b5846 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -1,2 +1,3 @@
DIST unison-2.51.5.tar.gz 1385407 BLAKE2B cdad4683518ec9c7c43d9107d8533fa393a68f602782d96ddba345df07b1ef70cc2ebf7dfd205fc7535349553a5e0d3c2931099bde99e5c736bc815ccdd294f8 SHA512 4a31df4d043d2b7552438f9fc2056098b9a35cd1cae1a037083cb56d91ec6fec0c3164de73914ff46cb8821f78c1594f48bf0334a94d9d706cd82ce3a6b70440
DIST unison-2.53.3.tar.gz 1415490 BLAKE2B 1142419781f5084da7ae8d043897f2f80aa4c3770a1c5cb44f8d7f669f718c41dd7fa6d13069cd95c71842233309eb886f63ab525e5e446ff761ea970de0e794 SHA512 f3fafd5e1a2950a00ed8bcc682036180ea40eff1ccfa1fc671cca49954890a535ee48faf1e8e62002563143e5479b9df1eca1db1caf03dffc50449fb467b8e2b
+DIST unison-2.53.5.tar.gz 1408926 BLAKE2B e7e3db458a485fca8820508a964df5877aed0a2d6a3ea8305298d0c6516591323f3cacdd86c4e057585c0f3b2da8a03a5a3653f543d6f1acb20701f23a81f470 SHA512 eabeed7b428f1985610b47ce8bc7faac515fd24937727612aa45435da3e38d40b6cd6d227eb3b65dc370d46458cecfca9d0e9e1712b2b7fa41b76675f8115c4c
diff --git a/net-misc/unison/unison-2.53.5.ebuild b/net-misc/unison/unison-2.53.5.ebuild
new file mode 100644
index 000000000000..95aaf5401b6c
--- /dev/null
+++ b/net-misc/unison/unison-2.53.5.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/
+ https://github.com/bcpierce00/unison/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bcpierce00/${PN}.git"
+else
+ SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+IUSE="doc gui +ocamlopt"
+
+BDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ doc? (
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex
+ )
+"
+DEPEND="
+ gui? (
+ dev-ml/lablgtk:3=[ocamlopt?]
+ )
+"
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=
+ gui? (
+ dev-ml/lablgtk:3=[ocamlopt?]
+ || (
+ net-misc/ssh-askpass-fullscreen
+ net-misc/x11-ssh-askpass
+ )
+ )
+"
+IDEPEND="
+ >=app-eselect/eselect-unison-0.4
+"
+
+DOCS=( CONTRIBUTING.md README.md src/FEATURES.md src/ROADMAP.txt src/TODO.txt )
+
+QA_FLAGS_IGNORED="usr/bin/${PN}-fsmonitor-${SLOT}"
+
+gui_cache_update() {
+ if use gui ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}
+
+src_compile() {
+ local -a myconf=()
+
+ if ! use ocamlopt ; then
+ myconf+=( NATIVE=false )
+ fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake "${myconf[@]}" CFLAGS="" -j1 tui fsmonitor manpage
+
+ if use gui ; then
+ emake "${myconf[@]}" CFLAGS="" -j1 gui
+ fi
+
+ if use doc ; then
+ VARTEXFONTS="${T}/fonts" emake "${myconf[@]}" CFLAGS="" HEVEA=false docs
+ fi
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ cd "${S}/src" || die
+
+ local -a bins=(
+ unison
+ unison-fsmonitor
+ )
+
+ if use gui ; then
+ bins+=( unison-gui )
+ fi
+
+ local binname
+ for binname in "${bins[@]}" ; do
+ exeinto /usr/bin
+ newexe "${binname}" "${binname}-${SLOT}"
+ done
+
+ cd "${S}" || die
+
+ doman "man/${PN}.1"
+
+ if use gui ; then
+ newicon -s scalable icons/U.svg "${PN}-${SLOT}.svg"
+ make_desktop_entry "${PN}-${SLOT}" "${PN^} GUI (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ if use doc ; then
+ DOCS+=( doc/unison-manual.pdf )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+
+ eselect unison update
+
+ gui_cache_update
+}
+
+pkg_postrm() {
+ eselect unison update
+
+ gui_cache_update
+}