summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2023-09-23 15:13:15 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2023-09-23 15:55:46 -0700
commit9719ac2fea815ef91d49c36e51d39262bbb69e8c (patch)
treef023e211f7ea16bb01cd4d0c7295abd2a1a80904 /net-misc
parentdev-db/redis: Stabilize 7.0.13 amd64, #914574 (diff)
downloadgentoo-9719ac2fea815ef91d49c36e51d39262bbb69e8c.tar.gz
gentoo-9719ac2fea815ef91d49c36e51d39262bbb69e8c.tar.bz2
gentoo-9719ac2fea815ef91d49c36e51d39262bbb69e8c.zip
net-misc/s4cmd: fix py3.10 issue per upstream PR
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/s4cmd/Manifest1
-rw-r--r--net-misc/s4cmd/metadata.xml3
-rw-r--r--net-misc/s4cmd/s4cmd-2.1.0-r2.ebuild (renamed from net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild)10
-rw-r--r--net-misc/s4cmd/s4cmd-2.1.0.ebuild29
4 files changed, 11 insertions, 32 deletions
diff --git a/net-misc/s4cmd/Manifest b/net-misc/s4cmd/Manifest
index 2f1d3e2af092..83de44f6b719 100644
--- a/net-misc/s4cmd/Manifest
+++ b/net-misc/s4cmd/Manifest
@@ -1,2 +1,3 @@
DIST s4cmd-2.1.0-botocore-fix.patch 2449 BLAKE2B 5158ded38f8e3417c090d274063a4eaa4f25cd5005c4bb8793cc639d3d87875f31d87464a8dbb44b5c1690570865cb01a0681f2e92edc46fa549828b91f30a0a SHA512 ea889d069a86a1d1f7f5cf5b1f19a9d0b35527c3db5eecf9202cca742ad4442655169d8688fc4b290a1362a0a794ba8ac44abf697ea7830acf8e48b6c7998ef6
+DIST s4cmd-2.1.0-py3-iter.patch 768 BLAKE2B 3e6bf42d40b87048521e1e3672bbb5c75a2d923696c85cfe9cd7140a388b483d830002354562ccc6017a8c8225799c0cb9ead2e136a37fec7ed0722e6ee99c39 SHA512 8070a987bf48c5832a80f39213125b4209141d1c35e612b26dce307fa621772741401f1da355b2a56e7869a3c76f4b91301d4aeae56f3810ce9a6ce6f9fd917b
DIST s4cmd-2.1.0.tar.gz 39312 BLAKE2B 9d2d533273543153f2bad69362933315f65c5e70bd45c102e42b1b733989815239ae4d027ac08d658f03263bd9dd75f1f6db802b5f38ed3256da5e7c9f48558c SHA512 05e930e2789ce8ab280dcdb2f08e4162930d946d2ed2e4f1c754c8b875375774779b73729151bd23d9bf3736bc48f7626fe53df66aff71dd11b32e90e9355470
diff --git a/net-misc/s4cmd/metadata.xml b/net-misc/s4cmd/metadata.xml
index aaab041e8885..2b826ec06b69 100644
--- a/net-misc/s4cmd/metadata.xml
+++ b/net-misc/s4cmd/metadata.xml
@@ -4,4 +4,7 @@
<maintainer type="person">
<email>robbat2@gentoo.org</email>
</maintainer>
+<upstream>
+ <remote-id type="github">bloomreach/s4cmd</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild b/net-misc/s4cmd/s4cmd-2.1.0-r2.ebuild
index 6be09aed0ddd..d80445061cdb 100644
--- a/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
+++ b/net-misc/s4cmd/s4cmd-2.1.0-r2.ebuild
@@ -3,17 +3,21 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1 bash-completion-r1
DESCRIPTION="Super S3 command line tool"
HOMEPAGE="https://github.com/bloomreach/s4cmd"
-SRC_URI="https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://github.com/bloomreach/s4cmd/pull/310.patch -> ${P}-botocore-fix.patch "
+SRC_URI="
+ https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/bloomreach/s4cmd/pull/162.patch -> ${P}-py3-iter.patch
+ https://github.com/bloomreach/s4cmd/pull/310.patch -> ${P}-botocore-fix.patch
+"
PATCHES=(
"${DISTDIR}/${P}-botocore-fix.patch"
+ "${DISTDIR}/${P}-py3-iter.patch"
)
LICENSE="GPL-2"
diff --git a/net-misc/s4cmd/s4cmd-2.1.0.ebuild b/net-misc/s4cmd/s4cmd-2.1.0.ebuild
deleted file mode 100644
index ad0c96c26eb5..000000000000
--- a/net-misc/s4cmd/s4cmd-2.1.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Super S3 command line tool"
-HOMEPAGE="https://github.com/bloomreach/s4cmd"
-SRC_URI="https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/boto3[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${P/_/-}"
-
-src_install() {
- distutils-r1_src_install
- dobashcomp data/bash-completion/s4cmd
- rm -f "${D}"/usr/bin/s4cmd.py
-}