summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2022-06-16 14:16:01 +0300
committerSam James <sam@gentoo.org>2022-06-16 17:35:04 +0100
commit21629bca1c0f37cb7740685ed488326a5f4b8987 (patch)
tree1a161af593243c2abfc7f15f4560beb04c714497 /net-misc/r8125
parentnet-misc/r8125: fixed build with kernel 5.18+ (diff)
downloadgentoo-21629bca1c0f37cb7740685ed488326a5f4b8987.tar.gz
gentoo-21629bca1c0f37cb7740685ed488326a5f4b8987.tar.bz2
gentoo-21629bca1c0f37cb7740685ed488326a5f4b8987.zip
net-misc/r8125: added new version 9.009.01
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/25923 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/r8125')
-rw-r--r--net-misc/r8125/Manifest1
-rw-r--r--net-misc/r8125/r8125-9.009.01.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/r8125/Manifest b/net-misc/r8125/Manifest
index 227f8d147425..45e8abd8602a 100644
--- a/net-misc/r8125/Manifest
+++ b/net-misc/r8125/Manifest
@@ -1 +1,2 @@
DIST r8125-9.008.00.tar.bz2 89622 BLAKE2B d1106086d1bca53484f8536072cddd506087b5d49983cbb91e921e86674c074b38c8a01cb51d2ea5793d8ffbff6e97ab05e48720ff00a805c4096a1d62a0cc30 SHA512 ff740a49fcc94b3de826f6299c489ed3f92ba9123ca2b2fe3c9035eecd16d518b6a4e6c2fa2531bb670c52097a52a0fb2fdf71b721efb20c83bb59d94d99c6c6
+DIST r8125-9.009.01.tar.bz2 89897 BLAKE2B 65f64f504cedc7244bdae10fd1638e031eb103f562cd71d32b5f36b15541704086df8cea16829b289e8be61bacf3de559616884d1672a4d6b8e47211816de8d3 SHA512 8b717447e2048df0d88d8350da2edb58f704e893498fbebea4aa2a3ac45ea050d70e73e78d41ab94562228b9c01e6fe59810c501c5bb880db446c05b9b6aee0d
diff --git a/net-misc/r8125/r8125-9.009.01.ebuild b/net-misc/r8125/r8125-9.009.01.ebuild
new file mode 100644
index 000000000000..2a1b7c235358
--- /dev/null
+++ b/net-misc/r8125/r8125-9.009.01.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8125 vendor driver for Realtek RTL8125 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8125(net:${S}/src)"
+BUILD_TARGETS="modules"
+IUSE="+multi-tx-q ptp +rss use-firmware"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-9.008.00-linux-5.18.patch" # bug 852311
+)
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${PN} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" ENABLE_PTP_SUPPORT=$(usex ptp y n)"
+ BUILD_PARAMS+=" ENABLE_RSS_SUPPORT=$(usex rss y n)"
+ BUILD_PARAMS+=" ENABLE_MULTIPLE_TX_QUEUE=$(usex multi-tx-q y n)"
+ BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}