summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pen')
-rw-r--r--net-misc/pen/Manifest1
-rw-r--r--net-misc/pen/metadata.xml7
-rw-r--r--net-misc/pen/pen-0.25.1.ebuild24
3 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/pen/Manifest b/net-misc/pen/Manifest
new file mode 100644
index 000000000000..b45f27f6e17d
--- /dev/null
+++ b/net-misc/pen/Manifest
@@ -0,0 +1 @@
+DIST pen-0.25.1.tar.gz 150231 SHA256 2dd9ca3b2f8057b9e59ddf07000a34649835ad23b45e6d34e8b9422d3dcb5270 SHA512 712c5899eb0ab20df1c91653328a63fe1715f0412e434aa08229555ff725bd54eb4732be1176f2cea02761db37a5ae241a4f790ca803fc1002be2bf65bc6269b WHIRLPOOL 22fb7c8c88415e303158e6a3fe203dd9a664be13f9cf8bdafe20502c07e2f06205d12000ed4b65a3fbaf4ee61d0a015b0e4d1b72a592b66814fb8114932f78bd
diff --git a/net-misc/pen/metadata.xml b/net-misc/pen/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-misc/pen/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/pen/pen-0.25.1.ebuild b/net-misc/pen/pen-0.25.1.ebuild
new file mode 100644
index 000000000000..04a756fc6b7f
--- /dev/null
+++ b/net-misc/pen/pen-0.25.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://siag.nu/pen/"
+SRC_URI="http://siag.nu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="geoip ssl"
+
+DEPEND="geoip? ( dev-libs/geoip )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-docdir=/usr/share/doc/${PF} \
+ $(use_with geoip) \
+ $(use_with ssl)
+}