summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2022-10-14 23:32:22 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2022-10-19 06:48:19 +0200
commitb44f361442e631027343bb22286d8392cecde6c6 (patch)
tree8923f948936a629040f8e88970c0c3e58384e7d2 /net-misc/kea
parentnet-misc/kea-9999: fix gtest patch rejection (diff)
downloadgentoo-b44f361442e631027343bb22286d8392cecde6c6.tar.gz
gentoo-b44f361442e631027343bb22286d8392cecde6c6.tar.bz2
gentoo-b44f361442e631027343bb22286d8392cecde6c6.zip
net-misc/kea: drop old
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'net-misc/kea')
-rw-r--r--net-misc/kea/Manifest1
-rw-r--r--net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch50
-rw-r--r--net-misc/kea/files/kea-1.8.2-gtest.patch149
-rw-r--r--net-misc/kea/kea-1.8.2-r1.ebuild112
4 files changed, 0 insertions, 312 deletions
diff --git a/net-misc/kea/Manifest b/net-misc/kea/Manifest
index 5107f3317c1b..08665ba991a5 100644
--- a/net-misc/kea/Manifest
+++ b/net-misc/kea/Manifest
@@ -1,3 +1,2 @@
-DIST kea-1.8.2.tar.gz 9005645 BLAKE2B fec1118ca34adc4bdafea13dd6c1c3abcd42df80043b621d1ed994e7ec6906a5d13e86a1bbb6dcbdfee32a4d70281c751b46c57d4866bd92557448ab7c602c30 SHA512 7bea9eb30ee819bd350ba3f64da7dc46d1176363e7243e934ff0f0498fcd47ef4eccb7fe8d8dd4f883ab9e376174aaba4fae06b20405181d46b6b12cfbdf7dd0
DIST kea-2.0.2.tar.gz 9796557 BLAKE2B a859c4cc3f6686db2dcf640738b421499a816700d134ee9322290051c3a192bab482be4a4bdb2630113594a3af1cafe2b95abce4a463815a6404fe87fac227ad SHA512 edb7de227898fb7bd76dd8b503d02e07b4ba512b907b53399a5c45bd216820b342f00c1834858848ce8ff94aa3c228ceead0e2946cbcb1f75a03ca579630be83
DIST kea-2.2.0.tar.gz 9999074 BLAKE2B 10b4bca1a135c6d146490f8c4c7bd4d56c1c03e2b4cc88a6888fcad5d1a5c2ee2d2c0215cb345b53a2a4262dbd02516d75d5778835d45384a7d69a062b8696b9 SHA512 82cd44efea8c968ef097de242e1ca59e0183c80df25050017fd45538d35da64a9a0d2f4a5249ad3bd3d30b1f8895c360d301518bc22e60dfddd966fe020dc773
diff --git a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
deleted file mode 100644
index 867561f2e7e5..000000000000
--- a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/m4macros/ax_cpp11.m4
-+++ b/m4macros/ax_cpp11.m4
-@@ -182,6 +182,7 @@
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <thread>
-+ #include <memory>
- std::shared_ptr<std::thread> th;],
- [th.reset(new std::thread([[]]() { return; }));
- th->join();])],
---- a/src/bin/perfdhcp/Makefile.am
-+++ b/src/bin/perfdhcp/Makefile.am
-@@ -3,7 +3,6 @@
- AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
- AM_CPPFLAGS += -I$(top_srcdir)/src/bin -I$(top_builddir)/src/bin
- AM_CPPFLAGS += $(BOOST_INCLUDES)
--AM_CPPFLAGS += -Werror
-
- AM_CXXFLAGS = $(KEA_CXXFLAGS)
-
---- a/src/bin/perfdhcp/tests/Makefile.am
-+++ b/src/bin/perfdhcp/tests/Makefile.am
-@@ -4,7 +4,6 @@
- AM_CPPFLAGS += -I$(srcdir)/.. -I$(builddir)/..
- AM_CPPFLAGS += -DTEST_DATA_DIR=\"$(abs_srcdir)/testdata\"
- AM_CPPFLAGS += $(BOOST_INCLUDES)
--AM_CPPFLAGS += -Werror
- AM_CXXFLAGS = $(KEA_CXXFLAGS)
-
- if USE_STATIC_LINK
---- a/src/lib/database/backend_selector.cc
-+++ b/src/lib/database/backend_selector.cc
-@@ -7,6 +7,7 @@
- #include <database/backend_selector.h>
- #include <exceptions/exceptions.h>
- #include <climits>
-+#include <limits>
- #include <sstream>
-
- using namespace isc::data;
---- a/src/lib/dhcpsrv/subnet_id.h
-+++ b/src/lib/dhcpsrv/subnet_id.h
-@@ -10,6 +10,7 @@
- #include <exceptions/exceptions.h>
- #include <stdint.h>
- #include <typeinfo>
-+#include <limits>
-
- namespace isc {
- namespace dhcp {
diff --git a/net-misc/kea/files/kea-1.8.2-gtest.patch b/net-misc/kea/files/kea-1.8.2-gtest.patch
deleted file mode 100644
index 5fa4488b926c..000000000000
--- a/net-misc/kea/files/kea-1.8.2-gtest.patch
+++ /dev/null
@@ -1,149 +0,0 @@
---- a/m4macros/ax_gtest.m4
-+++ b/m4macros/ax_gtest.m4
-@@ -1,24 +1,14 @@
- AC_DEFUN([AX_ISC_GTEST], [
-
--enable_gtest="no"
--GTEST_INCLUDES=
--
--AC_ARG_WITH([gtest-source],
-- [AS_HELP_STRING([--with-gtest-source=PATH],
-- [location of the Googletest source])],
-- [enable_gtest="yes" ; GTEST_SOURCE="$withval"])
--
--AC_ARG_WITH([gtest],
-- [AS_HELP_STRING([--with-gtest=PATH],
-- [specify a path to gtest header files (PATH/include) and library (PATH/lib)])],
-- [gtest_path="$withval"; enable_gtest="yes"], [gtest_path="no"])
-+AC_ARG_ENABLE([gtest],
-+ [AS_HELP_STRING([--enable-gtest],
-+ [Enable testing via Googletest [default=no]])])
-
- AC_ARG_WITH([lcov],
- [AS_HELP_STRING([--with-lcov=PROGRAM],
- [enable gtest and coverage target using the specified lcov])],
- [lcov="$withval"],
- [lcov="no"])
--
- USE_LCOV="no"
- if test "$lcov" != "no"; then
- # force gtest if not set
-@@ -55,110 +45,22 @@
- #
- # Check availability of gtest, which will be used for unit tests.
- #
--GTEST_LDFLAGS=
--GTEST_LDADD=
- DISTCHECK_GTEST_CONFIGURE_FLAG=
--GTEST_VERSION="unknown"
--
--if test "x$enable_gtest" = "xyes" ; then
--
-- DISTCHECK_GTEST_CONFIGURE_FLAG="--with-gtest=$gtest_path"
--
-- if test -n "$with_gtest_source" ; then
-
-- if test "x$GTEST_SOURCE" = "xyes" ; then
-+AS_IF([test "x$enable_gtest" = "xyes"], [
-+ DISTCHECK_GTEST_CONFIGURE_FLAG="--with-gtest"
-+ PKG_CHECK_MODULES([GTEST], [gtest], [], [AC_MSG_ERROR([gtest requested but not found])])
-+ GTEST_INCLUDES=`${PKG_CONFIG} --keep-system-cflags --cflags-only-I gtest`
-+ GTEST_LDFLAGS=`${PKG_CONFIG} --keep-system-libs --libs-only-L gtest`
-+ GTEST_VERSION=`${PKG_CONFIG} --modversion gtest`
-+])
-
-- AC_MSG_CHECKING([for gtest source])
-- # If not specified, try some common paths.
-- GTEST_SOURCE=
-- for d in /usr/src/gtest /usr/local /usr/pkg /opt /opt/local ; do
-- if test -f $d/src/gtest-all.cc -a $d/src/gtest_main.cc; then
-- GTEST_SOURCE=$d
-- AC_MSG_RESULT([$GTEST_SOURCE])
-- break
-- fi
-- done
-- if test -z $GTEST_SOURCE ; then
-- AC_MSG_ERROR([no gtest source but it was selected])
-- fi
-- else
-- if test ! -d $GTEST_SOURCE/src -a -d $GTEST_SOURCE/googletest; then
-- GTEST_SOURCE=$GTEST_SOURCE/googletest
-- fi
-- if test -f $GTEST_SOURCE/src/gtest-all.cc -a $GTEST_SOURCE/src/gtest_main.cc; then
-- have_gtest_source=yes
-- else
-- AC_MSG_ERROR([no gtest source at $GTEST_SOURCE])
-- fi
-- fi
-- have_gtest_source=yes
--
-- GTEST_LDADD="\$(top_builddir)/ext/gtest/libgtest.a"
-- DISTCHECK_GTEST_CONFIGURE_FLAG="--with-gtest-source=$GTEST_SOURCE"
-- GTEST_INCLUDES="-I$GTEST_SOURCE -I$GTEST_SOURCE/include"
-- GTEST_VERSION="`basename $GTEST_SOURCE`"
--
--# Versions starting from 1.8.0 are put in the googletest directory. If the basename
--# returns googletest string, we need to cut it off and try baseline again.
-- if test "$GTEST_VERSION" == "googletest"; then
-- GTEST_VERSION=${GTEST_SOURCE%"/googletest"}
-- GTEST_VERSION=`basename $GTEST_VERSION`
-- fi
-- GTEST_VERSION="${GTEST_VERSION#googletest-release-}"
-- GTEST_VERSION="${GTEST_VERSION#gtest-}"
-- fi
--
-- if test "$gtest_path" != "no" ; then
-- if test "$gtest_path" != "yes"; then
-- GTEST_PATHS=$gtest_path
-- if test -x "${gtest_path}/bin/gtest-config" ; then
-- GTEST_CONFIG="${gtest_path}/bin/gtest-config"
-- fi
-- else
-- AC_PATH_PROG([GTEST_CONFIG], [gtest-config])
-- fi
-- if test -x "${GTEST_CONFIG}" ; then :
-- # using cppflags instead of cxxflags
-- GTEST_INCLUDES=`${GTEST_CONFIG} --cppflags`
-- GTEST_LDFLAGS=`${GTEST_CONFIG} --ldflags`
-- GTEST_LDADD=`${GTEST_CONFIG} --libs`
-- GTEST_VERSION=`${GTEST_CONFIG} --version`
-- GTEST_FOUND="true"
-- else
-- AC_MSG_WARN([Unable to locate Google Test gtest-config.])
-- if test -z "${GTEST_PATHS}" ; then
-- GTEST_PATHS="/usr /usr/local"
-- fi
-- GTEST_FOUND="false"
-- fi
-- if test "${GTEST_FOUND}" != "true"; then
-- GTEST_FOUND="false"
-- for dir in $GTEST_PATHS; do
-- if test -f "$dir/include/gtest/gtest.h"; then
-- if ! test -f "$dir/lib/libgtest.a"; then
-- AC_MSG_WARN([Found Google Test include but not the library in $dir.])
-- continue
-- fi
-- GTEST_INCLUDES="-I$dir/include"
-- GTEST_LDFLAGS="-L$dir/lib"
-- GTEST_LDADD="-lgtest"
-- GTEST_FOUND="true"
-- break
-- fi
-- done
-- fi
-- if test "${GTEST_FOUND}" != "true"; then
-- AC_MSG_ERROR([Cannot find gtest in: $GTEST_PATHS])
-- fi
--
-- fi
--fi
- AM_CONDITIONAL(HAVE_GTEST, test $enable_gtest != "no")
- AM_CONDITIONAL(HAVE_GTEST_SOURCE, test "X$have_gtest_source" = "Xyes")
- AC_SUBST(DISTCHECK_GTEST_CONFIGURE_FLAG)
- AC_SUBST(GTEST_INCLUDES)
- AC_SUBST(GTEST_LDFLAGS)
--AC_SUBST(GTEST_LDADD)
-+AC_SUBST([GTEST_LDADD], [$GTEST_LIBS])
- AC_SUBST(GTEST_SOURCE)
-
- ])dnl AX_ISC_GTEST
diff --git a/net-misc/kea/kea-1.8.2-r1.ebuild b/net-misc/kea/kea-1.8.2-r1.ebuild
deleted file mode 100644
index 1a33c637752a..000000000000
--- a/net-misc/kea/kea-1.8.2-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV="${PV//_p/-P}"
-MY_PV="${MY_PV/_/-}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
-HOMEPAGE="https://www.isc.org/kea/"
-
-inherit autotools systemd tmpfiles
-
-if [[ ${PV} = 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/isc-projects/kea.git"
-else
- SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
- ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
- [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
-SLOT="0"
-IUSE="mysql +openssl postgres +samples test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- dev-libs/boost:=
- dev-libs/log4cplus
- mysql? ( dev-db/mysql-connector-c )
- !openssl? ( dev-libs/botan:2= )
- openssl? ( dev-libs/openssl:0= )
- postgres? ( dev-db/postgresql:* )
-"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-cpp/gtest )"
-RDEPEND="${COMMON_DEPEND}
- acct-group/dhcp
- acct-user/dhcp"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.2-fix-cxx11-detection.patch
- "${FILESDIR}"/${PN}-1.8.2-boost-1.77.0.patch
- "${FILESDIR}"/${PN}-1.8.2-gtest.patch
-)
-
-src_prepare() {
- default
- # Brand the version with Gentoo
- sed -i \
- -e "s/AC_INIT(kea,${PV}.*, kea-dev@lists.isc.org)/AC_INIT(kea,${PVR}-gentoo, kea-dev@lists.isc.org)/g" \
- configure.ac || die
-
- sed -i \
- -e '/mkdir -p $(DESTDIR)${runstatedir}\/${PACKAGE_NAME}/d' \
- Makefile.am || die "Fixing Makefile.am failed"
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-install-configurations
- --disable-static
- --enable-perfdhcp
- --localstatedir="${EPREFIX}/var"
- --runstatedir="${EPREFIX}/run"
- --without-werror
- $(use_with mysql)
- $(use_with openssl)
- $(use_with postgres pgsql)
- $(use_enable test gtest)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- newconfd "${FILESDIR}"/${PN}-confd-r1 ${PN}
- newinitd "${FILESDIR}"/${PN}-initd-r1 ${PN}
-
- if use samples; then
- diropts -m 0750 -o root -g dhcp
- dodir /etc/kea
- insopts -m 0640 -o root -g dhcp
- insinto /etc/kea
- doins "${FILESDIR}"/${PN}-ctrl-agent.conf
- doins "${FILESDIR}"/${PN}-ddns-server.conf
- doins "${FILESDIR}"/${PN}-dhcp4.conf
- doins "${FILESDIR}"/${PN}-dhcp6.conf
- fi
-
- systemd_dounit "${FILESDIR}"/${PN}-ctrl-agent.service
- systemd_dounit "${FILESDIR}"/${PN}-ddns-server.service
- systemd_dounit "${FILESDIR}"/${PN}-dhcp4-server.service
- systemd_dounit "${FILESDIR}"/${PN}-dhcp6-server.service
-
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf ${PN}.conf
-
- keepdir /var/lib/${PN} /var/log/${PN}
- find "${ED}" -type f -name "*.la" -delete || die
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
-}