summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-06 11:09:51 +0100
committerSam James <sam@gentoo.org>2023-09-06 11:09:52 +0100
commit4f820e90165cb71b87c468dcd05b34c35e08898f (patch)
tree1232e7c0a5d94238af67f11e160800b613a11478 /net-misc/curl
parentapp-editors/neovim: fix finding luajit in live (diff)
downloadgentoo-4f820e90165cb71b87c468dcd05b34c35e08898f.tar.gz
gentoo-4f820e90165cb71b87c468dcd05b34c35e08898f.tar.bz2
gentoo-4f820e90165cb71b87c468dcd05b34c35e08898f.zip
net-misc/curl: disable pthreads for mingw cross
Can't use kernel_Winnt (at least at the moment) as it's an implicit IUSE only in embedded profiles... Bug: https://bugs.gentoo.org/910605 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/curl-8.2.1.ebuild6
-rw-r--r--net-misc/curl/curl-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-misc/curl/curl-8.2.1.ebuild b/net-misc/curl/curl-8.2.1.ebuild
index 72c9069bc754..872fa57afa80 100644
--- a/net-misc/curl/curl-8.2.1.ebuild
+++ b/net-misc/curl/curl-8.2.1.ebuild
@@ -276,6 +276,12 @@ multilib_src_configure() {
)
fi
+ if [[ ${CHOST} == *mingw* ]] ; then
+ myconf+=(
+ --disable-pthreads
+ )
+ fi
+
ECONF_SOURCE="${S}" econf "${myconf[@]}"
if ! multilib_is_native_abi; then
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index 63a8fa2ec57b..044db08d02b5 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -282,6 +282,12 @@ multilib_src_configure() {
)
fi
+ if [[ ${CHOST} == *mingw* ]] ; then
+ myconf+=(
+ --disable-pthreads
+ )
+ fi
+
ECONF_SOURCE="${S}" econf "${myconf[@]}"
if ! multilib_is_native_abi; then