summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-14 18:30:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-14 18:31:39 +0100
commita51bb03daa7f2c74449464ce7d7f1d95aef88151 (patch)
tree21e7e6e5b4303b9db6b5d09e2f6dc094ee509f19 /net-libs
parentpackage.mask: Masked =app-arch/cpio-2.13 (diff)
downloadgentoo-a51bb03daa7f2c74449464ce7d7f1d95aef88151.tar.gz
gentoo-a51bb03daa7f2c74449464ce7d7f1d95aef88151.tar.bz2
gentoo-a51bb03daa7f2c74449464ce7d7f1d95aef88151.zip
net-libs/libktorrent: Fix build
Broken all of a sudden by... who knows what. Closes: https://bugs.gentoo.org/700090 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch25
-rw-r--r--net-libs/libktorrent/libktorrent-2.1.1.ebuild5
2 files changed, 29 insertions, 1 deletions
diff --git a/net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch b/net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch
new file mode 100644
index 000000000000..87d25e26b7be
--- /dev/null
+++ b/net-libs/libktorrent/files/libktorrent-2.1.1-fileops.patch
@@ -0,0 +1,25 @@
+From 1e8ce6e98d7ca0088624778964b9aed4696ce030 Mon Sep 17 00:00:00 2001
+From: Christoph Feck <cfeck@kde.org>
+Date: Thu, 14 Nov 2019 14:19:42 +0100
+Subject: Fix build with XFS
+
+BUG: 414050
+---
+ src/util/fileops.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/util/fileops.cpp b/src/util/fileops.cpp
+index c76b0e3..cfe4d5e 100644
+--- a/src/util/fileops.cpp
++++ b/src/util/fileops.cpp
+@@ -366,7 +366,7 @@ namespace bt
+
+ bool XfsPreallocate(const QString & path, Uint64 size)
+ {
+- int fd = ::open(QFile::encodeName(path), O_RDWR | O_LARGEFILE);
++ int fd = ::open(QFile::encodeName(path).constData(), O_RDWR | O_LARGEFILE);
+ if (fd < 0)
+ throw Error(i18n("Cannot open %1: %2",path,strerror(errno)));
+
+--
+cgit v1.1
diff --git a/net-libs/libktorrent/libktorrent-2.1.1.ebuild b/net-libs/libktorrent/libktorrent-2.1.1.ebuild
index 34a552aa1dc0..9399cfd161ba 100644
--- a/net-libs/libktorrent/libktorrent-2.1.1.ebuild
+++ b/net-libs/libktorrent/libktorrent-2.1.1.ebuild
@@ -36,7 +36,10 @@ RDEPEND="${COMMON_DEPEND}
!dev-libs/botan[gmp(-)]
"
-PATCHES=( "${FILESDIR}/${PN}-2.1-unused-link.patch" ) # git master
+PATCHES=(
+ "${FILESDIR}/${P}-fileops.patch" # bug 700090
+ "${FILESDIR}/${PN}-2.1-unused-link.patch" # git master
+)
src_prepare() {
kde5_src_prepare