summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-06-08 13:57:46 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-06-08 13:58:48 +0200
commitf2e4bbc44ec1f90456cf73a2c96daffe607a2a4f (patch)
treeeb5a9e08b1a0007dc49e8aaab352f42c5a68f269 /net-libs/xrootd
parentdev-cpp/scitokens-cpp: new package, add 1.0.1 (diff)
downloadgentoo-f2e4bbc44ec1f90456cf73a2c96daffe607a2a4f.tar.gz
gentoo-f2e4bbc44ec1f90456cf73a2c96daffe607a2a4f.tar.bz2
gentoo-f2e4bbc44ec1f90456cf73a2c96daffe607a2a4f.zip
net-libs/xrootd: add support for macaroons and scitokens
Closes: https://bugs.gentoo.org/834109 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/metadata.xml2
-rw-r--r--net-libs/xrootd/xrootd-5.5.5-r1.ebuild (renamed from net-libs/xrootd/xrootd-5.5.5.ebuild)13
2 files changed, 12 insertions, 3 deletions
diff --git a/net-libs/xrootd/metadata.xml b/net-libs/xrootd/metadata.xml
index 16c259164057..3b614243b413 100644
--- a/net-libs/xrootd/metadata.xml
+++ b/net-libs/xrootd/metadata.xml
@@ -20,6 +20,8 @@
<flag name="fuse">Enable the <pkg>sys-fs/fuse</pkg> filesystem driver</flag>
<flag name="http">Enable http protocol support</flag>
<flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for XML parsing (preferred) instead of bundled tinyxml</flag>
+ <flag name="macaroons">Enable support for macaroons with <pkg>dev-libs/libmacaroons</pkg></flag>
+ <flag name="scitokens">Enable support for scitokens with <pkg>dev-cpp/scitokens-cpp</pkg></flag>
<flag name="server">Install xrootd server and related plug-ins</flag>
<flag name="xrdec">Enable erasure coding support (XrdEc plugin) with <pkg>dev-libs/isa-l</pkg></flag>
</use>
diff --git a/net-libs/xrootd/xrootd-5.5.5.ebuild b/net-libs/xrootd/xrootd-5.5.5-r1.ebuild
index 9137e1925da2..7b7be06008c8 100644
--- a/net-libs/xrootd/xrootd-5.5.5.ebuild
+++ b/net-libs/xrootd/xrootd-5.5.5-r1.ebuild
@@ -23,7 +23,12 @@ SRC_URI="https://xrootd.slac.stanford.edu/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples fuse http kerberos +libxml2 python readline +server systemd test xrdec"
+IUSE="examples fuse http kerberos +libxml2 macaroons python readline scitokens +server systemd test xrdec"
+
+REQUIRED_USE="
+ macaroons? ( server )
+ scitokens? ( server )
+"
RESTRICT="!test? ( test )"
@@ -39,8 +44,10 @@ CDEPEND="acct-group/xrootd
)
kerberos? ( virtual/krb5 )
libxml2? ( dev-libs/libxml2:2= )
+ macaroons? ( dev-libs/libmacaroons )
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
+ scitokens? ( dev-cpp/scitokens-cpp )
systemd? ( sys-apps/systemd:= )
xrdec? ( dev-libs/isa-l )
"
@@ -98,10 +105,10 @@ src_configure() {
-DENABLE_FUSE=$(usex fuse)
-DENABLE_HTTP=$(usex http)
-DENABLE_KRB5=$(usex kerberos)
- -DENABLE_MACAROONS=no
+ -DENABLE_MACAROONS=$(usex macaroons)
-DENABLE_PYTHON=$(usex python)
-DENABLE_READLINE=$(usex readline)
- -DENABLE_SCITOKENS=no
+ -DENABLE_SCITOKENS=$(usex scitokens)
-DENABLE_TESTS=$(usex test)
-DENABLE_VOMS=no
-DENABLE_XRDCL=yes