summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-03 16:48:01 +0000
committerSam James <sam@gentoo.org>2023-02-03 16:51:38 +0000
commitfb830dbeedff348fc6d80661a6c01efb2ab90cb5 (patch)
tree67ad1b2016a58ec103ec3437a694c0366baf9a06 /net-libs/nDPI
parentdev-util/valgrind: drop 3.19.0, 3.20.0 (diff)
downloadgentoo-fb830dbeedff348fc6d80661a6c01efb2ab90cb5.tar.gz
gentoo-fb830dbeedff348fc6d80661a6c01efb2ab90cb5.tar.bz2
gentoo-fb830dbeedff348fc6d80661a6c01efb2ab90cb5.zip
net-libs/nDPI: add 4.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/nDPI')
-rw-r--r--net-libs/nDPI/Manifest1
-rw-r--r--net-libs/nDPI/nDPI-4.6.ebuild57
-rw-r--r--net-libs/nDPI/nDPI-9999.ebuild11
3 files changed, 64 insertions, 5 deletions
diff --git a/net-libs/nDPI/Manifest b/net-libs/nDPI/Manifest
index eaf6229a8f6a..cc2200b5f302 100644
--- a/net-libs/nDPI/Manifest
+++ b/net-libs/nDPI/Manifest
@@ -1,2 +1,3 @@
DIST nDPI-4.2.tar.gz 126559327 BLAKE2B 079267939083e788ce8b13e89b194504031e4c3e628df335ece7aab72cc80b8d8538badd45dac9fdaeeed8cd5dd19a81fece9c1157cba9a91dfa130abef61473 SHA512 c58b228b7de2b5fa111234bb065f9be259cd0282d0058f5985180aab6567c9a18e3453ce9062bd3c057a096ec3dfdc21b7c9680e0148e34af10f707530d853b8
DIST nDPI-4.4.tar.gz 151062073 BLAKE2B fca968c0d0abcf18a6895dc6066b754925a2aa3cb3f395383f9add25066adf14bb95444a30950e13f7f22223ff203b16e7373c875841f33d8c885be83ed0bb6d SHA512 c5e3d38f7b6533bd4b9f96520c1d965bf0a8e3ec7e2d514bc42683bdb73d8331e28ed695f5d3972ace9e35f1af23359f5a25c0f5a20f7a8cc7a6b5446d592468
+DIST nDPI-4.6.tar.gz 29705235 BLAKE2B 65efdfee7af83093b08897fb726a07cf804a3ff901e7373cdc4b3d4564bbfba6ce9b498ab90172f437568c8275685dc51617e991216e38d515b3b5341760b964 SHA512 12dd50eeaae0aa5c2e3c89cb53cdb9989036759bd900312d3875eaba296646c2e42be31dc2b003cbc2401ccef8fbf8d2e460b9a604d7bece360f17f937d60cad
diff --git a/net-libs/nDPI/nDPI-4.6.ebuild b/net-libs/nDPI/nDPI-4.6.ebuild
new file mode 100644
index 000000000000..704e7b7703e2
--- /dev/null
+++ b/net-libs/nDPI/nDPI-4.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edo
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ntop/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0/$(ver_cut 1)"
+
+DEPEND="dev-libs/json-c:=
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # "local" here means "local to the system", and hence means
+ # system copy, not the bundled one.
+ econf --with-local-libgcrypt
+}
+
+src_test() {
+ pushd tests || die
+
+ edo ./do.sh
+ edo ./do-unit.sh
+
+ popd || die
+}
+
+src_install() {
+ default
+
+ # Makefile logic is broken in 4.6, let's wait a bit given history and
+ # go with hack for now.
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/usr/$(get_libdir)/pkgconfig || die
+ mv "${ED}"/usr/usr/* "${ED}"/usr || die
+ rm "${ED}/usr/$(get_libdir)"/lib${PN,,}.a || die
+ rm -rf "${ED}"/usr/usr || die
+}
diff --git a/net-libs/nDPI/nDPI-9999.ebuild b/net-libs/nDPI/nDPI-9999.ebuild
index e2efa26265f9..704e7b7703e2 100644
--- a/net-libs/nDPI/nDPI-9999.ebuild
+++ b/net-libs/nDPI/nDPI-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,10 +27,6 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- sed -i \
- -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir = \${prefix}/$(get_libdir)%" \
- src/lib/Makefile.in || die
-
eautoreconf
}
@@ -52,5 +48,10 @@ src_test() {
src_install() {
default
+ # Makefile logic is broken in 4.6, let's wait a bit given history and
+ # go with hack for now.
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/usr/$(get_libdir)/pkgconfig || die
+ mv "${ED}"/usr/usr/* "${ED}"/usr || die
rm "${ED}/usr/$(get_libdir)"/lib${PN,,}.a || die
+ rm -rf "${ED}"/usr/usr || die
}