summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-12-12 19:19:23 -0500
committerNick Sarnie <sarnex@gentoo.org>2021-12-12 19:22:25 -0500
commitc13c5acc2855a5535370078e586c5bc6b06edf67 (patch)
treed424f2fa553cf723061305e11c5b42f331301d63 /net-libs/libtorrent-rasterbar
parentdev-util/clazy: Stabilize 1.10-r1 amd64, #810307 (diff)
downloadgentoo-c13c5acc2855a5535370078e586c5bc6b06edf67.tar.gz
gentoo-c13c5acc2855a5535370078e586c5bc6b06edf67.tar.bz2
gentoo-c13c5acc2855a5535370078e586c5bc6b06edf67.zip
net-libs/libtorrent-rasterbar: Fix build with boost 1.78
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org> Acked-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch46
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5.ebuild4
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch
new file mode 100644
index 000000000000..93e14963e366
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch
@@ -0,0 +1,46 @@
+From feb911a19c8a66bf13915973649d3a4f5d729f12 Mon Sep 17 00:00:00 2001
+From: arvidn <arvid@libtorrent.org>
+Date: Sun, 12 Dec 2021 21:52:15 +0100
+Subject: [PATCH] update allocator sizes for boost-1.78
+
+---
+ include/libtorrent/aux_/allocating_handler.hpp | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/include/libtorrent/aux_/allocating_handler.hpp b/include/libtorrent/aux_/allocating_handler.hpp
+index 726032e085c..7096dfd2e67 100644
+--- a/include/libtorrent/aux_/allocating_handler.hpp
++++ b/include/libtorrent/aux_/allocating_handler.hpp
+@@ -77,11 +77,11 @@ namespace libtorrent { namespace aux {
+ constexpr std::size_t openssl_write_cost = 0;
+ #endif
+
+- constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + 102 + 8 * sizeof(void*);
+- constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + 102 + 8 * sizeof(void*);
+- constexpr std::size_t udp_handler_max_size = tracking + debug_tick + 144 + 8 * sizeof(void*);
+- constexpr std::size_t utp_handler_max_size = tracking + debug_tick + 168 + 8 * sizeof(void*);
+- constexpr std::size_t tick_handler_max_size = tracking + debug_tick + 160;
++ constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + 102 + 9 * sizeof(void*);
++ constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + 102 + 9 * sizeof(void*);
++ constexpr std::size_t udp_handler_max_size = tracking + debug_tick + 144 + 9 * sizeof(void*);
++ constexpr std::size_t utp_handler_max_size = tracking + debug_tick + 168 + 9 * sizeof(void*);
++ constexpr std::size_t tick_handler_max_size = tracking + debug_tick + 168;
+ constexpr std::size_t abort_handler_max_size = tracking + debug_tick + 104;
+ constexpr std::size_t submit_handler_max_size = tracking + debug_tick + 104;
+ constexpr std::size_t deferred_handler_max_size = tracking + debug_tick + 112;
+@@ -124,12 +124,12 @@ namespace libtorrent { namespace aux {
+ #endif
+ constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 168;
+ constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 168;
+- constexpr std::size_t udp_handler_max_size = tracking + 160;
+- constexpr std::size_t utp_handler_max_size = tracking + 184;
++ constexpr std::size_t udp_handler_max_size = tracking + 168;
++ constexpr std::size_t utp_handler_max_size = tracking + 192;
+ constexpr std::size_t abort_handler_max_size = tracking + 72;
+ constexpr std::size_t submit_handler_max_size = tracking + 72;
+ constexpr std::size_t deferred_handler_max_size = tracking + 80;
+- constexpr std::size_t tick_handler_max_size = tracking + 128;
++ constexpr std::size_t tick_handler_max_size = tracking + 136;
+ #endif
+
+ enum HandlerName
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5.ebuild
index eee2529eecae..7df4947a91b8 100644
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5.ebuild
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5.ebuild
@@ -38,6 +38,10 @@ BDEPEND="python? (
')
)"
+PATCHES=(
+ "${FILESDIR}/${P}-boost-1.78.patch"
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}