summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-06 14:36:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-06 14:43:02 +0200
commit9f8a8f3ecf02f25260c1728abaafe4ddcdd7b0e5 (patch)
tree1a8c7c1910acb052a8ad158cb3009c30146cc75b /net-libs/libmicrohttpd
parentapp-office/scribus: add upstream patch for poppler-21.04.0 compatibility (diff)
downloadgentoo-9f8a8f3ecf02f25260c1728abaafe4ddcdd7b0e5.tar.gz
gentoo-9f8a8f3ecf02f25260c1728abaafe4ddcdd7b0e5.tar.bz2
gentoo-9f8a8f3ecf02f25260c1728abaafe4ddcdd7b0e5.zip
net-libs/libmicrohttpd: Revert remove vulnerable 0.9.68-r1, bug #778296
Partially reverts commit 79c54c122b2d260d80716930b04c66d43affa411 to fix CI, with KEYWORDS="amd64 x86" just for media-sound/sc2mpd. Bug: https://bugs.gentoo.org/778296 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.68-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 6b9656ba818f..f0e37d33206d 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1 +1,2 @@
+DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
DIST libmicrohttpd-0.9.72.tar.gz 1693553 BLAKE2B 24d9284d8cab65d4a5b6b7f3a5b860dfd8cf69b21e44ee05ae2f7561b766a72d2dbb7f57849a31c22454e211befa74e058f78814b79e7876b3d14c7252ab5800 SHA512 9695e2fb08785e4b60342226ef3a0af22da4d80f127e7db9ec80ce844f70d0d781b30af207d58d8eb691b85a5fe4691cb9ecf887ca86f5e059a05259ae041316
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.68-r1.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68-r1.ebuild
new file mode 100644
index 000000000000..05e8225d1ee3
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="amd64 x86"
+IUSE="+epoll ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( >net-libs/gnutls-2.12.20:= )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl[ssl?] )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}