summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Conway <mark.conway@themobiusproject.com>2023-06-25 19:51:01 -0500
committerSam James <sam@gentoo.org>2023-08-21 18:29:13 +0100
commitfac39f7470bcbcb959dc586da3b7bb51b6c974c4 (patch)
treee03bbb6bfec5b34be78f53879c7af503c6c8da2f /net-libs/grpc
parentdev-libs/protobuf: add 21.12 (diff)
downloadgentoo-fac39f7470bcbcb959dc586da3b7bb51b6c974c4.tar.gz
gentoo-fac39f7470bcbcb959dc586da3b7bb51b6c974c4.tar.bz2
gentoo-fac39f7470bcbcb959dc586da3b7bb51b6c974c4.zip
net-libs/grpc: version bump to 1.55.1
Closes: https://bugs.gentoo.org/908373 Signed-off-by: Mark Conway <mark.conway@themobiusproject.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/grpc')
-rw-r--r--net-libs/grpc/Manifest2
-rw-r--r--net-libs/grpc/grpc-1.55.1.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index 748c6d78954c..4fc21427782a 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -1 +1,3 @@
DIST grpc-1.52.1.tar.gz 8686340 BLAKE2B 0076ddd4a2840892f4ad11885e18f782b6a645337224974522c5f828d0226d6a1e19aaaf0f30ea3225d56118e0cfc251d45b8d5e6811c2d1a84e274ff037bb53 SHA512 06c69fb817af75b2610761a3a193178b749755eb7bed58875aa251def7c0c253cdaf02cf834c31c8b2cae7b01a6081e2aece4b131a162f64bd45ff0aff4d7758
+DIST grpc-1.55.1.tar.gz 9272441 BLAKE2B b2788d8deeb9791f04073294caa82c10e2cfe6376d09f396b51508a52f809e7f9f48d50ad5a62b2add652633b5c2d3b1ba07857b81111fa810202106251f440d SHA512 ecfa3a5affe33f160032f2ce42a9b44344d217359f68ee99305162ccabc911f44bc22512401183de74347e86add2ce20ec89da87ba6c14ab69874eb0835145d1
+DIST grpc-1.56.1.tar.gz 11750628 BLAKE2B 52ea088d3d19fa7c1d1dc44899cd67bfd0132df2fd37690d855194d3196e4c26cfdd6fe589b5e4f802cdf88e70aad6c33b3ee98c1bd1bc47356d0dee9cdc706d SHA512 2bf9619edb60a6cec4cdaa89ee3c470c52b9745ea954bfe205aef6eb29bb55949de02e8c2afc7352eacdcd33fe4000861fd16fda9e5f66c87222674b17d6322a
diff --git a/net-libs/grpc/grpc-1.55.1.ebuild b/net-libs/grpc/grpc-1.55.1.ebuild
new file mode 100644
index 000000000000..69d10308272e
--- /dev/null
+++ b/net-libs/grpc/grpc-1.55.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PV="${PV//_pre/-pre}"
+
+DESCRIPTION="Modern open source high performance RPC framework"
+HOMEPAGE="https://www.grpc.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+# format is 0/${CORE_SOVERSION//./}.${CPP_SOVERSION//./} , check top level CMakeLists.txt
+SLOT="0/32.155"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc examples test"
+
+# look for submodule versions in third_party dir
+RDEPEND="
+ =dev-cpp/abseil-cpp-20230125.2*:=
+ >=dev-libs/re2-0.2021.11.01:=
+ >=dev-libs/openssl-1.1.1:0=[-bindist(-)]
+ >=dev-libs/protobuf-22:=
+ dev-libs/xxhash
+ >=net-dns/c-ares-1.15.0:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gflags
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+# requires sources of many google tools
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+soversion_check() {
+ local core_sover cpp_sover
+ # extract quoted number. line we check looks like this: 'set(gRPC_CPP_SOVERSION "1.37")'
+ core_sover="$(grep 'set(gRPC_CORE_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ cpp_sover="$(grep 'set(gRPC_CPP_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ # remove dots, e.g. 1.37 -> 137
+ core_sover="${core_sover//./}"
+ cpp_sover="${cpp_sover//./}"
+ [[ ${core_sover} -eq $(ver_cut 2 ${SLOT}) ]] || die "fix core sublot! should be ${core_sover}"
+ [[ ${cpp_sover} -eq $(ver_cut 3 ${SLOT}) ]] || die "fix cpp sublot! should be ${cpp_sover}"
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # un-hardcode libdir
+ sed -i "s@/lib@/$(get_libdir)@" cmake/pkg-config-template.pc.in || die
+
+ # suppress network access, package builds fine without the submodules
+ mkdir "${S}/third_party/opencensus-proto/src" || die
+
+ soversion_check
+}
+
+src_configure() {
+ # https://github.com/grpc/grpc/issues/29652
+ filter-lto
+
+ local mycmakeargs=(
+ -DgRPC_INSTALL=ON
+ -DgRPC_INSTALL_CMAKEDIR="$(get_libdir)/cmake/${PN}"
+ -DgRPC_INSTALL_LIBDIR="$(get_libdir)"
+ -DgRPC_BACKWARDS_COMPATIBILITY_MODE=OFF
+ -DgRPC_ABSL_PROVIDER=package
+ -DgRPC_CARES_PROVIDER=package
+ -DgRPC_PROTOBUF_PROVIDER=package
+ -DgRPC_RE2_PROVIDER=package
+ -DgRPC_SSL_PROVIDER=package
+ -DgRPC_ZLIB_PROVIDER=package
+ -DgRPC_BUILD_TESTS=$(usex test)
+ $(usex test '-DgRPC_BENCHMARK_PROVIDER=package' '')
+ -DCMAKE_CXX_STANDARD=17
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ local DOCS=( AUTHORS CONCEPTS.md README.md TROUBLESHOOTING.md doc/. )
+ fi
+
+ einstalldocs
+}