summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-08 14:22:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-08 14:24:33 +0100
commit1a5157a5175d71ce17343f93b7a4dd6947dfe5d2 (patch)
tree6224988b13aa4bee31c99bdc8424429cb079fde1 /net-libs/accounts-qml
parentkde-misc/zanshin: Drop 0.5.0-r1 (diff)
downloadgentoo-1a5157a5175d71ce17343f93b7a4dd6947dfe5d2.tar.gz
gentoo-1a5157a5175d71ce17343f93b7a4dd6947dfe5d2.tar.bz2
gentoo-1a5157a5175d71ce17343f93b7a4dd6947dfe5d2.zip
net-libs/accounts-qml: New package
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/accounts-qml')
-rw-r--r--net-libs/accounts-qml/Manifest1
-rw-r--r--net-libs/accounts-qml/accounts-qml-0.7.ebuild50
-rw-r--r--net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch14
-rw-r--r--net-libs/accounts-qml/metadata.xml8
4 files changed, 73 insertions, 0 deletions
diff --git a/net-libs/accounts-qml/Manifest b/net-libs/accounts-qml/Manifest
new file mode 100644
index 000000000000..fa099087241c
--- /dev/null
+++ b/net-libs/accounts-qml/Manifest
@@ -0,0 +1 @@
+DIST accounts-qml-module-VERSION_0.7.tar.gz 62029 BLAKE2B 0924b73868135ad5d9ec7545d5b0ba84f140053f0be4d17f1c6d3754ec19e362af906af60fb45e6405b5d080dd8f63845070815b12e8bfeda30032c9ed172708 SHA512 4e0e5df64d0a477e11f412c0def85d0de1730efff9682790f5339a57d58778282aa8ca0fa201e409b3b9a2a75fea70f10555b1f70224a3b95ab8d44b942cf7e1
diff --git a/net-libs/accounts-qml/accounts-qml-0.7.ebuild b/net-libs/accounts-qml/accounts-qml-0.7.ebuild
new file mode 100644
index 000000000000..b5307447aaa6
--- /dev/null
+++ b/net-libs/accounts-qml/accounts-qml-0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="QML bindings for accounts-qt and signond"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}-module/-/archive/VERSION_${PV}/${PN}-module-VERSION_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ net-libs/accounts-qt
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ )
+"
+
+# dbus problems
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-no-tests.patch" )
+
+S="${WORKDIR}/${PN}-module-VERSION_${PV}"
+
+src_prepare() {
+ default
+ sed -e 's/-Werror//' -i common-project-config.pri || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install_subtargets
+}
diff --git a/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch b/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch
new file mode 100644
index 000000000000..cfe8dec082bb
--- /dev/null
+++ b/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch
@@ -0,0 +1,14 @@
+--- a/accounts-qml-module.pro 2016-06-08 09:26:26.000000000 +0200
++++ b/accounts-qml-module.pro 2019-12-08 14:16:24.058806381 +0100
+@@ -5,8 +5,9 @@
+ TEMPLATE = subdirs
+ CONFIG += ordered
+ SUBDIRS = \
+- src \
+- tests
++ src
++
++CONFIG(tests): SUBDIRS += tests
+
+ include(common-installs-config.pri)
+
diff --git a/net-libs/accounts-qml/metadata.xml b/net-libs/accounts-qml/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/net-libs/accounts-qml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>