summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-02-14 18:36:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-22 15:46:40 +0200
commit37ffd8ed45f8d54199763eb2eb073fa32045d002 (patch)
tree2e65fcdb9427d91ba24339ec7ccea17854b9b082 /net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild
parentsys-apps/portage: Remove old version 3.0.9 (diff)
downloadgentoo-37ffd8ed45f8d54199763eb2eb073fa32045d002.tar.gz
gentoo-37ffd8ed45f8d54199763eb2eb073fa32045d002.tar.bz2
gentoo-37ffd8ed45f8d54199763eb2eb073fa32045d002.zip
net-im/bitlbee-facebook: bump to 1.2.2
Closes: https://bugs.gentoo.org/769722 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild')
-rw-r--r--net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild b/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild
new file mode 100644
index 000000000000..d28c1fce5d93
--- /dev/null
+++ b/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2017-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Facebook protocol plugin for BitlBee"
+HOMEPAGE="https://github.com/bitlbee/bitlbee-facebook"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bitlbee/bitlbee-facebook"
+else
+ SRC_URI="https://github.com/bitlbee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=net-im/bitlbee-3[plugins]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}