summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-07-14 07:59:35 -0500
committerBen Kohler <bkohler@gentoo.org>2023-07-14 08:00:44 -0500
commitf91561053cb81e6201fab93523b17e60f12d2493 (patch)
tree1007f53459241bc20b87ca523a41136789ae6711 /net-dns/openresolv/openresolv-3.13.2-r1.ebuild
parentsys-apps/memtest86+: stabilize 6.20-r1 for amd64, x86 (diff)
downloadgentoo-f91561053cb81e6201fab93523b17e60f12d2493.tar.gz
gentoo-f91561053cb81e6201fab93523b17e60f12d2493.tar.bz2
gentoo-f91561053cb81e6201fab93523b17e60f12d2493.zip
net-dns/openresolv: update EAPI 7 -> 8, drop PDEPEND
It's been decided that resolvconf-symlink should really be something explicitly opt-in, as it changes or breaks behavior on some setups. Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-dns/openresolv/openresolv-3.13.2-r1.ebuild')
-rw-r--r--net-dns/openresolv/openresolv-3.13.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/openresolv/openresolv-3.13.2-r1.ebuild b/net-dns/openresolv/openresolv-3.13.2-r1.ebuild
new file mode 100644
index 000000000000..6c0232d79c9b
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.13.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="https://roy.marples.name/projects/openresolv"
+SRC_URI="https://github.com/NetworkConfiguration/openresolv/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="!sys-apps/systemd[resolvconf]
+ selinux? ( sec-policy/selinux-resolvconf )"
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --rundir="${EPREFIX}"/var/run
+ --libexecdir="${EPREFIX}"/lib/resolvconf
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_config() {
+ if [[ -n ${ROOT} ]]; then
+ eerror "We cannot configure unless \$ROOT is empty"
+ return 1
+ fi
+
+ if [[ -n "$(resolvconf -l)" ]]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}
+
+DOCS=( LICENSE README.md )