summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-15 14:23:02 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-15 14:24:20 +0200
commitd5d67c0957df506b5ef54680274fc707b42c4337 (patch)
tree749f1efe1b39c12a09789cc8c0358ddb8fef18ed /net-dns/libidn2
parentdev-php/PEAR-PEAR: Mark ~hppa (bug #613380). (diff)
downloadgentoo-d5d67c0957df506b5ef54680274fc707b42c4337.tar.gz
gentoo-d5d67c0957df506b5ef54680274fc707b42c4337.tar.bz2
gentoo-d5d67c0957df506b5ef54680274fc707b42c4337.zip
net-dns/libidn2: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-dns/libidn2')
-rw-r--r--net-dns/libidn2/Manifest1
-rw-r--r--net-dns/libidn2/libidn2-2.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-dns/libidn2/Manifest b/net-dns/libidn2/Manifest
index 6e94e500633c..ea57bda7c61d 100644
--- a/net-dns/libidn2/Manifest
+++ b/net-dns/libidn2/Manifest
@@ -1 +1,2 @@
DIST libidn2-0.16.tar.gz 1494295 SHA256 2fad9efff4082ae2143f69df76339ca99379e0e0f4231455f5d3d9d2089c688f SHA512 85f41c79bd2b88f2724383461a78e56b47e52e66e3f088d631a922438742938721d26aeebef17f6ca4fd028d95dfb5b0fa298a96982ef777c07fefe5244d1e73 WHIRLPOOL be10d0e2994e4fa0e31d710b358c7375e9454b4291bd4603a683a6ddb737241442007f04893395b36d7ef636614b6982354840bb07570e2a6b8f6aa2d888996a
+DIST libidn2-2.0.0.tar.xz 1257908 SHA256 039052f2a3c513c56b9961b8afb7379e68a0698032e228953e89b169b88d7838 SHA512 0cc199f05526edebb385cd7ca3bafca341e31cc76ef0efe7e63a07ff1d2830d9d33004dfc51aa245b42fdf0de7eeb807fd18255f58cc2b086e1155beaa738502 WHIRLPOOL daa222e6a3527cbc989a0388cb903e428acd759553e668b97f2ca2b9071067e43a6c23a8b3e52e7bbd98c71788b2ee009ce5f640a09051b5fcca04a50b543d2d
diff --git a/net-dns/libidn2/libidn2-2.0.0.ebuild b/net-dns/libidn2/libidn2-2.0.0.ebuild
new file mode 100644
index 000000000000..20634db29527
--- /dev/null
+++ b/net-dns/libidn2/libidn2-2.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/jas/libidn2"
+SRC_URI="
+ mirror://gnu-alpha/libidn/${P}.tar.xz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ sys-apps/help2man
+"
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # crude hack, fixed properly for next release, no error.h is present
+ sed -i -e '/#include "error\.h"/d' src/idn2.c || die
+ append-cppflags -D'error\(E,...\)=exit\(E\)'
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-gtk-doc
+}
+
+multilib_src_install() {
+ default
+
+ rm "${D}"/usr/bin/idn2_noinstall || die
+
+ prune_libtool_files
+}