summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-10-26 21:21:31 +0200
committerSam James <sam@gentoo.org>2022-11-23 01:43:10 +0000
commit2f4ed11c2d13ddb7ed61730295e3e9e72648eddc (patch)
treee0bf27d260fdad0b649678d4701adc43b4fc37dc /net-analyzer
parentdev-libs/libowfat: prevent recompile during install (diff)
downloadgentoo-2f4ed11c2d13ddb7ed61730295e3e9e72648eddc.tar.gz
gentoo-2f4ed11c2d13ddb7ed61730295e3e9e72648eddc.tar.bz2
gentoo-2f4ed11c2d13ddb7ed61730295e3e9e72648eddc.zip
net-analyzer/shodan: new package, add 1.28.0, 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/shodan/Manifest1
-rw-r--r--net-analyzer/shodan/metadata.xml22
-rw-r--r--net-analyzer/shodan/shodan-1.28.0.ebuild36
-rw-r--r--net-analyzer/shodan/shodan-9999.ebuild36
4 files changed, 95 insertions, 0 deletions
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
new file mode 100644
index 000000000000..692d15a254a3
--- /dev/null
+++ b/net-analyzer/shodan/Manifest
@@ -0,0 +1 @@
+DIST shodan-1.28.0.gh.tar.gz 51277 BLAKE2B e2cd4c322ccdd1d81c998dc810c56b85de903afe9c3a59adc231d382779806909a78e994ff163639468dd9af1e8f7a547953b0e2304ac167ed7cf9c437d69adc SHA512 cb2476faf2c435d29823635e5262bdf6b224b2a5f19b77513fb6e920f4d042b15a7fd23cea7e2a29bc73b00be188dfac16f945fba090da28a72d0342357232c3
diff --git a/net-analyzer/shodan/metadata.xml b/net-analyzer/shodan/metadata.xml
new file mode 100644
index 000000000000..506479336f85
--- /dev/null
+++ b/net-analyzer/shodan/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Shodan is a search engine for Internet-connected devices. Google lets
+ you search for websites, Shodan lets you search for devices. This
+ library provides developers easy access to all of the data stored in
+ Shodan in order to automate tasks and integrate into existing tools.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">achillean/shodan-python</remote-id>
+ <remote-id type="pypi">shodan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/shodan/shodan-1.28.0.ebuild b/net-analyzer/shodan/shodan-1.28.0.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.28.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"
diff --git a/net-analyzer/shodan/shodan-9999.ebuild b/net-analyzer/shodan/shodan-9999.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"