summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/pypacker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/pypacker')
-rw-r--r--net-analyzer/pypacker/Manifest2
-rw-r--r--net-analyzer/pypacker/metadata.xml12
-rw-r--r--net-analyzer/pypacker/pypacker-2.4.ebuild31
-rw-r--r--net-analyzer/pypacker/pypacker-2.9.ebuild31
4 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
new file mode 100644
index 000000000000..90e8b418bc80
--- /dev/null
+++ b/net-analyzer/pypacker/Manifest
@@ -0,0 +1,2 @@
+DIST pypacker-2.4.tar.gz 239409 SHA256 c6369350a5a3a083f2b660a3b2f64573e94ea6032fea17f1a37d6590289ac097 SHA512 aaafea17b8c2ecd59682ece430720dc5cd4c1d08d2d839adb8530e848f3e677de9f4a06138cf612b58f76e182b4524491d5e6685c90696071fe125d3340958cf WHIRLPOOL ddc4bd60087fd5a63a597ca016efd5cb8c891f174ec6316c913f7610a99262d14b93aa37d6701411c23e56ec924801d53ebc7c67ab9caed18a715311a11259a5
+DIST pypacker-2.9.tar.gz 276080 SHA256 8eff9e7002b2fdf3bee9d3b7b7a44fedb9a88a7f53666fb1e2a6c0e4ab4c450c SHA512 b7ca61948a55a37661fa402ebc5a9c2be456e8df14d1ee091a50ccd1362c7a7fa9224e1ae2b8ee8057f302ee9e0c61c06d07b627dde92947f8d22158ef3623b8 WHIRLPOOL b7eace8e170f4997cccd1b0ca7c817ad9bdcb232b3fc854e890e22735e1995a81363902ab285f94edc9c725dcba54db3c917bfddfb96ebd8e464bf4d4dc631b8
diff --git a/net-analyzer/pypacker/metadata.xml b/net-analyzer/pypacker/metadata.xml
new file mode 100644
index 000000000000..5c2b33cc7476
--- /dev/null
+++ b/net-analyzer/pypacker/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="github">mike01/pypacker</remote-id>
+ <maintainer>
+ <email>michael.stahn.42@googlemail.com</email>
+ <name>Michael Stahn</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/pypacker/pypacker-2.4.ebuild b/net-analyzer/pypacker/pypacker-2.4.ebuild
new file mode 100644
index 000000000000..8e652f6985e4
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://github.com/mike01/pypacker"
+SRC_URI="https://github.com/mike01/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}
diff --git a/net-analyzer/pypacker/pypacker-2.9.ebuild b/net-analyzer/pypacker/pypacker-2.9.ebuild
new file mode 100644
index 000000000000..52b90b5127e5
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-2.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://github.com/mike01/pypacker"
+SRC_URI="https://github.com/mike01/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}