summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ostinato
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ostinato')
-rw-r--r--net-analyzer/ostinato/Manifest1
-rw-r--r--net-analyzer/ostinato/files/protobuf-2.4.0.diff11
-rw-r--r--net-analyzer/ostinato/metadata.xml11
-rw-r--r--net-analyzer/ostinato/ostinato-0.5.1.ebuild26
4 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/Manifest b/net-analyzer/ostinato/Manifest
new file mode 100644
index 000000000000..22643bd51294
--- /dev/null
+++ b/net-analyzer/ostinato/Manifest
@@ -0,0 +1 @@
+DIST ostinato-src-0.5.1.tar.gz 291529 SHA256 fa19c857d73837cae23aa15d7309c1ddcf22c6f7be9f3ed15a23948142b24223 SHA512 d06b59dc2129aba01e5a42a677339d6e8f353f9c7c027226e66c8a5af94ecb48e8450e7770ae5e179131fa4cfeefcc827fb9a18be4294ddfcd7a471ec26ee06a WHIRLPOOL 6027729df2f880a220a2a4a55c702dab53ddd33ebafe6bd20740bd875498cfb8876917ea63fe981811b70ee57e7cc3c347bcba5182c6b061420b40e4bf3f3ffc
diff --git a/net-analyzer/ostinato/files/protobuf-2.4.0.diff b/net-analyzer/ostinato/files/protobuf-2.4.0.diff
new file mode 100644
index 000000000000..4d42b253a844
--- /dev/null
+++ b/net-analyzer/ostinato/files/protobuf-2.4.0.diff
@@ -0,0 +1,11 @@
+--- common/protocol.proto 2010-11-08 11:47:19.000000000 -0500
++++ common/protocol.proto.new 2011-04-18 13:54:03.725337006 -0400
+@@ -19,6 +19,8 @@
+
+ package OstProto;
+
++option cc_generic_services = true;
++
+ message StreamId {
+ required uint32 id = 1;
+ }
diff --git a/net-analyzer/ostinato/metadata.xml b/net-analyzer/ostinato/metadata.xml
new file mode 100644
index 000000000000..2fab0a213dec
--- /dev/null
+++ b/net-analyzer/ostinato/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ostinato</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/ostinato/ostinato-0.5.1.ebuild b/net-analyzer/ostinato/ostinato-0.5.1.ebuild
new file mode 100644
index 000000000000..6f69c0b6ad7d
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-0.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-r2
+
+DESCRIPTION="A packet generator and analyzer"
+HOMEPAGE="http://code.google.com/p/ostinato/"
+SRC_URI="http://ostinato.googlecode.com/files/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DEPEND="dev-libs/protobuf:=
+ net-libs/libpcap
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 PREFIX=/usr ost.pro
+}