summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 04:33:21 +0000
committerSam James <sam@gentoo.org>2021-04-16 04:40:20 +0000
commit40383a04ef95327b961084eecd00076f2e47233b (patch)
treec1d2e6552f6ede74537037c8403870265e02436a /net-analyzer/nmap
parentnet-analyzer/nmap: add verify-sig support (diff)
downloadgentoo-40383a04ef95327b961084eecd00076f2e47233b.tar.gz
gentoo-40383a04ef95327b961084eecd00076f2e47233b.tar.bz2
gentoo-40383a04ef95327b961084eecd00076f2e47233b.zip
net-analyzer/nmap: use live template
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/nmap-7.91-r2.ebuild29
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild25
2 files changed, 43 insertions, 11 deletions
diff --git a/net-analyzer/nmap/nmap-7.91-r2.ebuild b/net-analyzer/nmap/nmap-7.91-r2.ebuild
index 6778cf910514..492355ccf044 100644
--- a/net-analyzer/nmap/nmap-7.91-r2.ebuild
+++ b/net-analyzer/nmap/nmap-7.91-r2.ebuild
@@ -5,17 +5,29 @@ EAPI=7
LUA_COMPAT=( lua5-3 )
LUA_REQ_USE="deprecated"
-VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/nmap.asc
-inherit autotools lua-single toolchain-funcs verify-sig
+inherit autotools lua-single toolchain-funcs
DESCRIPTION="Network exploration tool and security / port scanner"
HOMEPAGE="https://nmap.org/"
-SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
-SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/nmap/nmap"
+
+ # Just in case for now as future seems undecided.
+ LICENSE="NPSL"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/nmap.asc
+ inherit verify-sig
+
+ SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
+ SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
+
+ LICENSE="|| ( NPSL GPL-2 )"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
-LICENSE="|| ( NPSL GPL-2 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="ipv6 libressl libssh2 ncat nping +nse ssl +system-lua"
REQUIRED_USE="system-lua? ( nse ${LUA_REQUIRED_USE} )"
@@ -35,7 +47,10 @@ RDEPEND="
system-lua? ( ${LUA_DEPS} )
"
DEPEND="${RDEPEND}"
-BDEPEND+="verify-sig? ( app-crypt/openpgp-keys-nmap )"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+="verify-sig? ( app-crypt/openpgp-keys-nmap )"
+fi
PATCHES=(
"${FILESDIR}"/${PN}-5.10_beta1-string.patch
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 0b9f3ddf3650..fa6114906f22 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -5,15 +5,28 @@ EAPI=7
LUA_COMPAT=( lua5-3 )
LUA_REQ_USE="deprecated"
-
-inherit autotools git-r3 lua-single toolchain-funcs
+inherit autotools lua-single toolchain-funcs
DESCRIPTION="Network exploration tool and security / port scanner"
HOMEPAGE="https://nmap.org/"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/nmap/nmap"
+
+ # Just in case for now as future seems undecided.
+ LICENSE="NPSL"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/nmap.asc
+ inherit verify-sig
-EGIT_REPO_URI="https://github.com/nmap/nmap"
+ SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
+ SRC_URI+=" verify-sig? ( https://nmap.org/dist/sigs/${P}.tar.bz2.asc )"
+
+ LICENSE="|| ( NPSL GPL-2 )"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
-LICENSE="NPSL"
SLOT="0"
IUSE="ipv6 libressl libssh2 ncat nping +nse ssl +system-lua"
REQUIRED_USE="system-lua? ( nse ${LUA_REQUIRED_USE} )"
@@ -35,6 +48,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+="verify-sig? ( app-crypt/openpgp-keys-nmap )"
+fi
+
PATCHES=(
"${FILESDIR}"/${PN}-5.10_beta1-string.patch
"${FILESDIR}"/${PN}-5.21-python.patch