summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-31 19:52:50 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-31 19:59:07 +0200
commit356d4a2484d986cd5b767d98e58ea9f192a06642 (patch)
tree713a48a1455f42abb43ccc9387db416741da6cdd /net-analyzer/cacti-spine
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-356d4a2484d986cd5b767d98e58ea9f192a06642.tar.gz
gentoo-356d4a2484d986cd5b767d98e58ea9f192a06642.tar.bz2
gentoo-356d4a2484d986cd5b767d98e58ea9f192a06642.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.1.20.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index b0eb2c176e00..77f7579de3f4 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-0.8.8h.tar.gz 804951 SHA256 a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30 SHA512 6a7147ab645be44de0d330c7801e569705817da10bf6cedba82c712e1701ada8aa8924a6b3b063ea680e6af24f815d6767e8773ad7b8da212abfa082b4211bd4 WHIRLPOOL 36daed4986ca84883e51ab6b02ebb2ade00205c30705cfc94e73835bc2fc427a60a2dba9c7ca3665d0c0b2fca21afab77d94cde63b740f3734f9279c929cccaf
DIST cacti-spine-1.1.18.tar.gz 801575 SHA256 0c12426ae880f9f7296c91a2930781f63f7c50217e210c9e8faf75614f415f48 SHA512 28fb6a7c67289680dd4eac08b08099b72cbf4676f4a86c6d4d158e2c791e59855ea39770badb214709868c7405022fba88348c968883a9cb3bb734c251c192c7 WHIRLPOOL 389c64c10775bbebf3043e0ff9c4ce544024941a5fe4704f20abae34e1063c21a956ffa5a59d157266937304be4a2031db71f8b152563fe954b4d0a911846159
+DIST cacti-spine-1.1.20.tar.gz 801877 SHA256 a8ccb24980099fbb6ee0a16f397f10fb9b3320db6a02c4e61b1483445d405f99 SHA512 df552157e64da04f57493351831a0602dea9ca3219ce3936884aec894e6698559d429ec62936a307b43fd49eff674c670d7e0a047924b5f03c30abeeec91491f WHIRLPOOL 1948229141f99fb04c799b46b323a047c47dc3c94303cb50f56018af8cbc1fe4d2c3a5b8c1683629802b3600e6e69b8ab5ce636e0d9c84ba61e9beadde11f2f1
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.1.20.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.1.20.ebuild
new file mode 100644
index 000000000000..fa4ecb956b8d
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.1.20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}