summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-12 21:36:31 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-26 09:10:48 -0500
commitc43979542ebb3f7b7880c321a0f5f327eacdf855 (patch)
tree764738e95f9c1eb37c2374fd07f8b1d791c5cecb /media-video
parentdev-python/APScheduler: disable broken tests (diff)
downloadgentoo-c43979542ebb3f7b7880c321a0f5f327eacdf855.tar.gz
gentoo-c43979542ebb3f7b7880c321a0f5f327eacdf855.tar.bz2
gentoo-c43979542ebb3f7b7880c321a0f5f327eacdf855.zip
media-video/ffmpeg: Add srt use flag
Closes: https://bugs.gentoo.org/655434 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.0.3.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-4.1.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
4 files changed, 7 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.0.3.ebuild b/media-video/ffmpeg/ffmpeg-4.0.3.ebuild
index 4c7c281769c8..ad72c8b4ebbf 100644
--- a/media-video/ffmpeg/ffmpeg-4.0.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.0.3.ebuild
@@ -76,7 +76,7 @@ FFMPEG_FLAG_MAP=(
amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
+ speex:libspeex srt:libsrt svg:librsvg video_cards_nvidia:ffnvcodec
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
@@ -229,6 +229,7 @@ RDEPEND="
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ srt? ( net-libs/srt[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
svg? ( gnome-base/librsvg:2=[${MULTILIB_USEDEP}] )
truetype? ( >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/ffmpeg-4.1.ebuild b/media-video/ffmpeg/ffmpeg-4.1.ebuild
index 6cda905ec7ab..5c79e1ee666e 100644
--- a/media-video/ffmpeg/ffmpeg-4.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.1.ebuild
@@ -76,7 +76,7 @@ FFMPEG_FLAG_MAP=(
amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
+ speex:libspeex srt:libsrt svg:librsvg video_cards_nvidia:ffnvcodec
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
@@ -229,6 +229,7 @@ RDEPEND="
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ srt? ( net-libs/srt[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
svg? ( gnome-base/librsvg:2=[${MULTILIB_USEDEP}] )
truetype? ( >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 2a10fdca9482..6968c4b4fb12 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -76,7 +76,7 @@ FFMPEG_FLAG_MAP=(
amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
+ speex:libspeex srt:libsrt svg:librsvg video_cards_nvidia:ffnvcodec
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
@@ -229,6 +229,7 @@ RDEPEND="
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
+ srt? ( net-libs/srt[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
svg? ( gnome-base/librsvg:2=[${MULTILIB_USEDEP}] )
truetype? ( >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 7ad4c88a08be..ac9e4e532cc4 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -52,6 +52,7 @@
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
<flag name="sofalizer">Enables Sofalizer filter</flag>
+ <flag name="srt">Enable support for Secure Reliable Transport (SRT) via <pkg>net-libs/srt</pkg></flag>
<flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>
<flag name="twolame">Enables MP2 encoding via <pkg>media-sound/twolame</pkg> as an alternative to the internal encoder.</flag>
<flag name="vpx">Enables vp8 codec support using libvpx: Decoding vp8 does not require this to be enabled but libvpx can also be used for decoding; encoding vp8 requires this useflag to be enabled though.</flag>