summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-22 15:39:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-22 15:39:32 +0100
commit9a5b2e2c86cac682039068befc5248bb50f0c896 (patch)
tree29d197fa4063b6c4888da58472820d9e1ae79cc0 /media-sound
parentdev-lang/mmix: drop old (diff)
downloadgentoo-9a5b2e2c86cac682039068befc5248bb50f0c896.tar.gz
gentoo-9a5b2e2c86cac682039068befc5248bb50f0c896.tar.bz2
gentoo-9a5b2e2c86cac682039068befc5248bb50f0c896.zip
media-sound/mmix: block against dev-lang/mmix, bug #426874
Reported-by: Diego Elio Pettenò Closes: https://bugs.gentoo.org/426874 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mmix/mmix-0.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mmix/mmix-0.3-r1.ebuild b/media-sound/mmix/mmix-0.3-r1.ebuild
new file mode 100644
index 000000000000..f00dba606ab5
--- /dev/null
+++ b/media-sound/mmix/mmix-0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A soundcard mixer for the OSS driver"
+HOMEPAGE="http://www.mcmilk.de/projects/mmix/"
+SRC_URI="http://www.mcmilk.de/projects/${PN}/dl/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# media-sound/mmix and dev-lang/mmix both install 'mmix' binary, bug #426874
+RDEPEND=""
+DEPEND="virtual/os-headers"
+
+src_prepare() {
+ default
+ sed -i -e '/strip/d' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman doc/${PN}.1
+ dodoc doc/{AUTHORS,CHANGES,FAQ,README}
+}