summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-09 20:31:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-10 10:30:46 +0100
commit14e45109cabd59407a3d0a2c9f43d0e3892525db (patch)
treeb333bd08b9d2ef880cdea4d5ce42864aeaa8c7d2 /media-sound
parentmedia-sound/sndio: drop 1.8.0 (diff)
downloadgentoo-14e45109cabd59407a3d0a2c9f43d0e3892525db.tar.gz
gentoo-14e45109cabd59407a3d0a2c9f43d0e3892525db.tar.bz2
gentoo-14e45109cabd59407a3d0a2c9f43d0e3892525db.zip
media-sound/sndio: add 1.10.0, bump subslot, use more https
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sndio/Manifest1
-rw-r--r--media-sound/sndio/sndio-1.10.0.ebuild53
-rw-r--r--media-sound/sndio/sndio-9999.ebuild16
3 files changed, 62 insertions, 8 deletions
diff --git a/media-sound/sndio/Manifest b/media-sound/sndio/Manifest
index 09c5535dae7e..d89477937ba1 100644
--- a/media-sound/sndio/Manifest
+++ b/media-sound/sndio/Manifest
@@ -1,2 +1,3 @@
+DIST sndio-1.10.0.tar.gz 162725 BLAKE2B 6c804c175c86296763df7ba2f2e142dc509f4a52eb2d54b3bb76113e2a5594630c99297e558b5932cda143383f2cfd42be84d30160e72c8b5fa76d4f7246d43b SHA512 c35462976a1bffd128eacb185165964dac6b03505255e9ab9a933e24be5ed146cd9ac6995fd7af23247cb9133c010cce0876572db53b783ebabeb563fec7a1cf
DIST sndio-1.8.0.tar.gz 156249 BLAKE2B 46d279c0a9ab40253d9f4abf5892d6c2cbbbeeeeb5ff72f45287b16adce122550025ee2d50b45de5e6952dfac1f25041e520692b0afc31ce9cfa5e122d8799fa SHA512 c3225e59e50c3dee41df7df1d87d32ed616117ea6883d9c643a57091b2239b03988c00230882c32f68331952852781dccb8bdc5a6c92780d97a294a1bd9d8ef8
DIST sndio-1.9.0.tar.gz 157354 BLAKE2B d7e5f8137f87096a0260679afba84e4952bb060e28df6cb9a184fb4436b627a0fc8260cc29e459f3cca4d10372f96424f18e19ddf5805d281cbb8c538fbfffa2 SHA512 f322886e428a4b5bf6867f9faaeaea26d377babbf4176960a0287ebcb0b678bf3cbac134c6c08838c9bd2094a68286be2f2df71ca0f55b7b0e816fdea9cd41cf
diff --git a/media-sound/sndio/sndio-1.10.0.ebuild b/media-sound/sndio/sndio-1.10.0.ebuild
new file mode 100644
index 000000000000..c844afa2e83c
--- /dev/null
+++ b/media-sound/sndio/sndio-1.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="Small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="https://sndio.org/"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://caoua.org/git/sndio"
+ EGIT_MIN_CLONE_TYPE="single+tags"
+else
+ SRC_URI="https://sndio.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0/7.3"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}
+ acct-user/sndiod
+"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ # Not autotools-based but a custom script
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}
diff --git a/media-sound/sndio/sndio-9999.ebuild b/media-sound/sndio/sndio-9999.ebuild
index b796a1c0aa71..5bd89433fb71 100644
--- a/media-sound/sndio/sndio-9999.ebuild
+++ b/media-sound/sndio/sndio-9999.ebuild
@@ -1,23 +1,23 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit multilib-minimal toolchain-funcs
-DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
-HOMEPAGE="http://www.sndio.org/"
-if [[ "${PV}" == "9999" ]]; then
+DESCRIPTION="Small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="https://sndio.org/"
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://caoua.org/git/sndio"
EGIT_MIN_CLONE_TYPE="single+tags"
else
- SRC_URI="http://www.sndio.org/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://sndio.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
LICENSE="ISC"
-SLOT="0/7.1"
+SLOT="0/7.3"
IUSE="alsa"
DEPEND="
@@ -37,7 +37,7 @@ src_prepare() {
multilib_src_configure() {
tc-export CC
- # Not autotools-based but a custom one.
+ # Not autotools-based but a custom script
./configure \
--prefix="${EPREFIX}"/usr \
--libdir="${EPREFIX}"/usr/$(get_libdir) \