summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-25 12:25:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-25 12:33:04 +0200
commitcc5093682a6b275be29515f8c229bdb9602073fa (patch)
treec13234f05b6ce63e0746ca8d63d3817512137217 /media-sound/spotify-tray
parentmail-client/thunderbird: add 102.10.1 (diff)
downloadgentoo-cc5093682a6b275be29515f8c229bdb9602073fa.tar.gz
gentoo-cc5093682a6b275be29515f8c229bdb9602073fa.tar.bz2
gentoo-cc5093682a6b275be29515f8c229bdb9602073fa.zip
media-sound/spotify-tray: move spotify-tray executable
This avoids launching in a loop, i.e. launching spotify-tray from command line by default launches /usr/bin/spotify but we customized this script to launch spotify-tray if available. Avoid the problem by moving the executable out of PATH so it is not used by accident and causing confusion. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-sound/spotify-tray')
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild (renamed from media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
index dc3be566510a..6630dbac467e 100644
--- a/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
+++ b/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,4 +34,8 @@ src_install() {
default
# remove desktop file, launching is handled in spotify ebuild
rm "${ED}/usr/share/applications/spotify-tray.desktop" || die
+
+ # move executable outside of PATH to avoid accidentally launching it in a loop
+ mkdir -p "${ED}/opt/spotify/spotify-client" || die
+ mv "${ED}/usr/bin/spotify-tray" "${ED}/opt/spotify/spotify-client/spotify-tray" || die
}