summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-dvbapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-dvbapi')
-rw-r--r--media-plugins/vdr-dvbapi/Manifest1
-rw-r--r--media-plugins/vdr-dvbapi/metadata.xml12
-rw-r--r--media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild78
3 files changed, 91 insertions, 0 deletions
diff --git a/media-plugins/vdr-dvbapi/Manifest b/media-plugins/vdr-dvbapi/Manifest
new file mode 100644
index 000000000000..0261db63fa7d
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/Manifest
@@ -0,0 +1 @@
+DIST vdr-dvbapi-2.1.1.tar.gz 82813 SHA256 2724768de00a607d7119478296a3ad1cc592c12badbc95480edc5f7e6b3985d7 SHA512 fb632e66c9e477663eb1edf5e630a20b2165495c89d5bd6294d74d6a28c8386021d90914c9c6b958ea3c5c1d0958cc69efa5c65ef72c510c224d676f1eca39ae WHIRLPOOL af18c22bb00ddbb41aa8e3ee091f27a1bb7b79f0d90783af9c9503ad03a568193c88cc41db86e0e06fd8c503ad43242a582b0decc5f64c417283517f05d14727
diff --git a/media-plugins/vdr-dvbapi/metadata.xml b/media-plugins/vdr-dvbapi/metadata.xml
new file mode 100644
index 000000000000..e947c6b9b74b
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>hd_brummy@gentoo.org</email>
+ <name>Joerg Bornkessel</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">manio/vdr-plugin-dvbapi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild
new file mode 100644
index 000000000000..68b823f164d5
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: allows connect VDR to OScam"
+HOMEPAGE="https://github.com/manio/vdr-plugin-dvbapi"
+SRC_URI="https://github.com/manio/vdr-plugin-dvbapi/archive/v${PV}.tar.gz -> vdr-dvbapi-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DEPEND=">=media-video/vdr-2.1.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/vdr-plugin-dvbapi-${PV}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # respect the system CXXFLAGS
+ sed -e "s:FLAGS:CXXFLAGS:" -i FFdecsa/Makefile
+
+ # Prepare flags for FFdeCSA
+ if [ -n "${VDR_DVBAPI_PARALLEL}" ]; then
+ PARALLEL="${VDR_DVBAPI_PARALLEL}"
+ else
+ # [32/64] Core2 (SSSE3) achieves best results with SSE2 & SSE
+ # [64] Athlon64 (SSE2) does much better with 64_LONG
+ # [32] Athlon64 (SSE2) does best with MMX
+ # [32] Pentium4 & Atom (SSE2) work best with SSE2 & SSE
+ # [32] AthlonXP (SSE) has MMX faster
+
+ # To avoid parsing -march=, we use ugly assumption that Intels don't
+ # have 3dnow and AMDs do. SSE achieves good results only on Intel CPUs,
+ # and LONG is best on 64-bit AMD CPUs.
+
+ if ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse2; then
+ PARALLEL=PARALLEL_128_SSE2
+ elif ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse; then
+ PARALLEL=PARALLEL_128_SSE
+ elif use amd64; then
+ PARALLEL=PARALLEL_64_LONG
+ elif use cpu_flags_x86_mmx; then
+ PARALLEL=PARALLEL_64_MMX
+ else
+ # fallback values:
+ # PARALLEL_32_INT fails with gcc4.4 on x86&amd64
+ # PARALLEL_64_2INT fails with gcc4.4 on x86
+ # PARALLEL_128_4INT seems to be the fastest non-failing fallback
+ PARALLEL=PARALLEL_128_4INT
+ fi
+
+ ewarn "VDR_DVBAPI_PARALLEL in your system make.conf is not set, guessing value from USEflags (${PARALLEL})."
+ ewarn "This setting may be suboptimal, so you'll probably want to tweak it yourself."
+ ewarn "\n\tRun the script ${WORKDIR}/extra/FFdecsa-benchmark.sh"
+ ewarn "\tand add the output parameter from PARALLEL= to your system make.conf"
+ ewarn "\tVDR_DVBAPI_PARALLEL= your parameter"
+ fi
+
+ export PARALLEL
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "This software might be illegal in some countries or violate"
+ elog "rules of your DVB provider"
+ elog "Please respect these rules.\n"
+
+ elog "We do not offer support of any kind"
+ elog "Asking for keys or for installation help will be ignored by gentoo developers!\n"
+}