summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-01-09 15:24:47 -0500
committerDavid Seifert <soap@gentoo.org>2017-01-09 22:25:55 +0200
commit2825b6e93761621c6162913df20b21169df024c8 (patch)
tree9bad032591663c2da65d9c2f00b06ff74e2cc45c /media-plugins/kodi-pvr-mythtv
parentdev-python/ansicolor: add missing dev-python/setuptools DEPEND (diff)
downloadgentoo-2825b6e93761621c6162913df20b21169df024c8.tar.gz
gentoo-2825b6e93761621c6162913df20b21169df024c8.tar.bz2
gentoo-2825b6e93761621c6162913df20b21169df024c8.zip
media-plugins/kodi-*: add live ebuilds for all add-ons currently available in kodi upstream
Gentoo-bug: 555792 Closes: https://github.com/gentoo/gentoo/pull/3195
Diffstat (limited to 'media-plugins/kodi-pvr-mythtv')
-rw-r--r--media-plugins/kodi-pvr-mythtv/Manifest1
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.12.11.ebuild36
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild36
-rw-r--r--media-plugins/kodi-pvr-mythtv/metadata.xml16
4 files changed, 89 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-mythtv/Manifest b/media-plugins/kodi-pvr-mythtv/Manifest
new file mode 100644
index 000000000000..f23b60958e3c
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/Manifest
@@ -0,0 +1 @@
+DIST kodi-pvr-mythtv-4.12.11.tar.gz 652826 SHA256 3ac4a9ff51f7ae8c3161b350d16ebada262161e3228efc92904e31ec44cb95cf SHA512 2b729dc6ec933ef829ceff48300642f3ee8c9441532bc5024d767196d137d6a567a5e5cff32e9b982b0787aff1c804c2178d56b0b7c3a40a241a8293a203320a WHIRLPOOL dbb035156e306fcc4ddbe713d9243c190d86f51b6a8a38641a21d4e4176e12d5d4925f06433aed29570f86d8daca1f24955e889248ce092abf5c7a938f2e1da2
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.12.11.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.12.11.ebuild
new file mode 100644
index 000000000000..13bd69041ff9
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.12.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
new file mode 100644
index 000000000000..13bd69041ff9
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-mythtv/metadata.xml b/media-plugins/kodi-pvr-mythtv/metadata.xml
new file mode 100644
index 000000000000..f40040ec5117
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>MythTV PVR for Kodi</longdescription>
+ <upstream>
+ <remote-id type="github">janbar/pvr.mythtv</remote-id>
+ </upstream>
+</pkgmetadata>