summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-03 21:23:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-03 21:27:51 -0400
commit63d3591d9d03416e5a39e0020ecbb35f3be33ccb (patch)
tree2befd92be48e9105efe9eccdcca247c4258f7ee0 /media-libs
parentsys-fs/zfs-kmod: Stabilize 2.1.12 ppc64, #911673 (diff)
downloadgentoo-63d3591d9d03416e5a39e0020ecbb35f3be33ccb.tar.gz
gentoo-63d3591d9d03416e5a39e0020ecbb35f3be33ccb.tar.bz2
gentoo-63d3591d9d03416e5a39e0020ecbb35f3be33ccb.zip
media-libs/libplacebo: adjust old interpreter patch
Re-looking at this, it may be worth upstreaming sometime by using find_program() if really nothing that needs find_installation(). Fortunately setuptools issues hardly occured with 3.12 because we check for jinja which pulled setuptools. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
index 35486262c992..181e281bfde1 100644
--- a/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
@@ -1,5 +1,7 @@
-Upstream bundles python deps and uses same interpreter as meson,
-but we don't and need this to use the eclass' python3 instead.
+Ensure we get the interpreter from python-any-r1 rather than same
+as meson. Plus find_program() is quicker than find_installation(),
+and the latter also needs distutils that is unavailable with
+python3_12 without setuptools.
https://bugs.gentoo.org/731728
--- a/meson.build
@@ -7,5 +9,5 @@ https://bugs.gentoo.org/731728
@@ -323,3 +323,3 @@
thirdparty = meson.project_source_root()/'3rdparty'
-python = import('python').find_installation()
-+python = import('python').find_installation('python3')
++python = find_program('python3')
python_env = environment()