summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Schmelting <l3s8g@posteo.eu>2023-09-16 17:34:40 +0200
committerMatt Turner <mattst88@gentoo.org>2023-09-16 12:06:57 -0400
commit61c55cf650af95acbc1262957e35a54fe4aa5c6f (patch)
tree88cc6f06a3f531491435b9462da5f7b187c4fe4b /media-libs
parentdev-python/moto: Bump to 4.2.3 (diff)
downloadgentoo-61c55cf650af95acbc1262957e35a54fe4aa5c6f.tar.gz
gentoo-61c55cf650af95acbc1262957e35a54fe4aa5c6f.tar.bz2
gentoo-61c55cf650af95acbc1262957e35a54fe4aa5c6f.zip
media-libs/libshumate: Version bump to 1.1.0
Signed-off-by: Lukas Schmelting <l3s8g@posteo.eu> Closes: https://github.com/gentoo/gentoo/pull/32833 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libshumate/Manifest1
-rw-r--r--media-libs/libshumate/libshumate-1.1.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
index 8122227443f8..d08a7a99713e 100644
--- a/media-libs/libshumate/Manifest
+++ b/media-libs/libshumate/Manifest
@@ -1,2 +1,3 @@
DIST libshumate-1.0.5.tar.xz 112008 BLAKE2B e20e53fdcd34aa67853f68d72801e7ef7dfcb39670f67f0bfab76cc04a0dc4e92b614b5a588560de64c85406b63a105b5ba19854cf1189a5a3c03f097c93556e SHA512 73beffb8eea95b279d297294ce96a39883856d280eeda1215b908d5b7ac86aff49bbd9c07065ffb394657497997b1994712de6526efd9076f9a5feb1c17b9532
+DIST libshumate-1.1.0.tar.xz 299096 BLAKE2B 111eaca1ed7d0abc9f4bc5d83c10bd84aadd42cf92d3a5ac37e00edd9b433c1db768686c9935f7f88b200c6a2b7c1898b0e96bcf036947bc7097e5ddfcd34d82 SHA512 138736090ad448cd73812e5b3da6d1e9199601ca7ee9b026a19586c680ccb306871fe2a779db4cffde822834974154ccd55117dd58ce849c655fde71dab0237a
DIST libshumate-1.1.rc.tar.xz 298976 BLAKE2B d2bde2edec21df575ab61ef7bd0564bc4d328cbd989de8fb98f74a9a084ad6fc81236d7f3cc0a99fa7538e3297dd71cc54d55e4c74d03bc368e93a1c88e2a406 SHA512 b4093ac48b09794064989b34e36737f90901685220db686aed8cb896af5d0f2b9165f4fed59cadb2e43ff49211fcd54a4e6d64bca9c73311cd1822f8e455723e
diff --git a/media-libs/libshumate/libshumate-1.1.0.ebuild b/media-libs/libshumate/libshumate-1.1.0.ebuild
new file mode 100644
index 000000000000..0238d92667b6
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection sysprof vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ $(meson_feature sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/html/libshumate-1.0 || die
+ fi
+}