summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-05 10:46:22 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-05 22:48:59 +0200
commit245433f13fe772c0e87ee2e375e25f0fdbf2b464 (patch)
treef8e1453b278a7f5b514a5ee5ee5484b0d9e8b821 /media-libs
parentmedia-libs/esdl: use HTTPS (diff)
downloadgentoo-245433f13fe772c0e87ee2e375e25f0fdbf2b464.tar.gz
gentoo-245433f13fe772c0e87ee2e375e25f0fdbf2b464.tar.bz2
gentoo-245433f13fe772c0e87ee2e375e25f0fdbf2b464.zip
media-libs/esdl: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/31762 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/esdl/esdl-1.3.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/esdl/esdl-1.3.1-r1.ebuild b/media-libs/esdl/esdl-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..0908e7ca6aed
--- /dev/null
+++ b/media-libs/esdl/esdl-1.3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Erlang bindings for the SDL library"
+HOMEPAGE="https://esdl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/esdl/${P}.src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="image truetype"
+
+RDEPEND="
+ >=dev-lang/erlang-14[wxwidgets]
+ media-libs/libsdl[opengl]
+ image? ( media-libs/sdl-image )
+ truetype? ( media-libs/sdl-ttf )
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/rebar:0"
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ ESDL_DIR="${ERLANG_DIR}/${P}"
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${ESDL_DIR}
+ doins -r ebin c_src include priv src
+}