summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-15 00:52:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-06 23:20:59 +0200
commit64e49bf02c10178003bd87bd27ad303bd3e118da (patch)
tree2e5ce882384e0a1def2d495d5f9d497373832c62 /media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
parentprofiles: Mask kde-plasma/plasma-sdk[plasmate] on arm (diff)
downloadgentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.tar.gz
gentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.tar.bz2
gentoo-64e49bf02c10178003bd87bd27ad303bd3e118da.zip
media-libs/qimageblitz: Add Qt5-based snapshot
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild')
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
new file mode 100644
index 000000000000..edeaa2ce759c
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical effect and filter library by KDE"
+HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="http://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 debug qt5"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT4_BUILD=$(usex !qt5)
+ -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
+ -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
+ -DHAVE_SSE=$(usex cpu_flags_x86_sse)
+ -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+ use ppc && mycmakeargs+=( -DHAVE_ALTIVEC=$(usex altivec) )
+
+ cmake-utils_src_configure
+}