summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-11-30 06:01:15 +0200
committerAmy Liffey <amynka@gentoo.org>2019-11-30 20:47:39 +0100
commit2dfae79d6eb34ffd11bd31342e340d92d47ec6a8 (patch)
tree97551dbb5604d080c61dc34cc21854a0d8e0f4c7 /media-libs/opencv
parentmedia-libs/opencv: add cv_cpu_dispatch.h to MULTILIB_WRAPPED_HEADERS (diff)
downloadgentoo-2dfae79d6eb34ffd11bd31342e340d92d47ec6a8.tar.gz
gentoo-2dfae79d6eb34ffd11bd31342e340d92d47ec6a8.tar.bz2
gentoo-2dfae79d6eb34ffd11bd31342e340d92d47ec6a8.zip
media-libs/opencv: add USE=+features2d
USE=contribxfeatures2d should not control building features2d module. Add USE=+features2d instead. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Stefan Strogin <steils@gentoo.org> Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/metadata.xml1
-rw-r--r--media-libs/opencv/opencv-4.1.2-r1.ebuild4
2 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/opencv/metadata.xml b/media-libs/opencv/metadata.xml
index fa1de56873eb..f7bccfa408e7 100644
--- a/media-libs/opencv/metadata.xml
+++ b/media-libs/opencv/metadata.xml
@@ -15,6 +15,7 @@ Face Recognition; Gesture Recognition; Motion Tracking, Ego Motion, Motion Under
<flag name="cuda">Enable NVIDIA Cuda computations support (Experimental!)</flag>
<flag restrict="&gt;=media-libs/opencv-4.1.2" name="download">Enable download during cmake configure</flag>
<flag name="eigen">Enable usage of <pkg>dev-cpp/eigen</pkg> for computations</flag>
+ <flag name="features2d">Enable features2d module</flag>
<flag name="gdal">Enable support for sci-libs/gdal library</flag>
<flag restrict="&gt;=media-libs/opencv-4.1.2" name="opencvapps">Enable compilation with opencvapps</flag>
<flag restrict="&gt;=media-libs/opencv-3.1.0" name="gflags">Use Google's C++ argument parsing library</flag>
diff --git a/media-libs/opencv/opencv-4.1.2-r1.ebuild b/media-libs/opencv/opencv-4.1.2-r1.ebuild
index 9b2a7e66419a..b897cdd744ad 100644
--- a/media-libs/opencv/opencv-4.1.2-r1.ebuild
+++ b/media-libs/opencv/opencv-4.1.2-r1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD"
SLOT="0/4.1.2" # subslot = libopencv* soname version
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="contrib contribcvv contribdnn contribhdf contribsfm contribxfeatures2d cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_popcnt cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cuda debug dnnsamples -download +eigen examples ffmpeg gdal gflags glog gphoto2 gstreamer gtk ieee1394 jpeg jpeg2k lapack libav opencl openexr opengl openmp opencvapps pch png +python qt5 tesseract testprograms threads tiff vaapi v4l vtk webp xine"
+IUSE="contrib contribcvv contribdnn contribhdf contribsfm contribxfeatures2d cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_popcnt cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cuda debug dnnsamples -download +eigen examples +features2d ffmpeg gdal gflags glog gphoto2 gstreamer gtk ieee1394 jpeg jpeg2k lapack libav opencl openexr opengl openmp opencvapps pch png +python qt5 tesseract testprograms threads tiff vaapi v4l vtk webp xine"
# OpenGL needs gtk or Qt installed to activate, otherwise build system
# will silently disable it Wwithout the user knowing, which defeats the
# purpose of the opengl use flag.
@@ -410,7 +410,7 @@ multilib_src_configure() {
-DOPENCV_CPU_OPT_IMPLIES_IGNORE=ON
-DCPU_BASELINE=$(printf "%s," "${cpu_flags[@]}")
-DCPU_DISPATCH=
- -DBUILD_opencv_features2d=$(usex contribxfeatures2d)
+ -DBUILD_opencv_features2d=$(usex features2d ON OFF)
)
# ===================================================