summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:29:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:24 +0100
commit1f9f1999cdc8ccb94054dec2d2951c7e486aa996 (patch)
tree083f072f5a45564fcf8937b43274d14b4d6a037e /media-libs/mesa
parentMove {sys-devel → llvm-core}/llvm-common (diff)
downloadgentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.tar.gz
gentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.tar.bz2
gentoo-1f9f1999cdc8ccb94054dec2d2951c7e486aa996.zip
Move {sys-devel → llvm-core}/llvm
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-24.1.7-r1.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.3-r1.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.4-r1.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.5-r1.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.6-r2.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.7.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.2.8.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.3.0.ebuild6
-rw-r--r--media-libs/mesa/mesa-24.3.0_rc2.ebuild6
-rw-r--r--media-libs/mesa/mesa-9999.ebuild6
10 files changed, 30 insertions, 30 deletions
diff --git a/media-libs/mesa/mesa-24.1.7-r1.ebuild b/media-libs/mesa/mesa-24.1.7-r1.ebuild
index 07aacd364494..3bc7670467fe 100644
--- a/media-libs/mesa/mesa-24.1.7-r1.ebuild
+++ b/media-libs/mesa/mesa-24.1.7-r1.ebuild
@@ -96,7 +96,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -273,8 +273,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.3-r1.ebuild b/media-libs/mesa/mesa-24.2.3-r1.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.3-r1.ebuild
+++ b/media-libs/mesa/mesa-24.2.3-r1.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.4-r1.ebuild b/media-libs/mesa/mesa-24.2.4-r1.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.4-r1.ebuild
+++ b/media-libs/mesa/mesa-24.2.4-r1.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.5-r1.ebuild b/media-libs/mesa/mesa-24.2.5-r1.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.5-r1.ebuild
+++ b/media-libs/mesa/mesa-24.2.5-r1.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.6-r2.ebuild b/media-libs/mesa/mesa-24.2.6-r2.ebuild
index aba8aca921d8..949cec8c6d99 100644
--- a/media-libs/mesa/mesa-24.2.6-r2.ebuild
+++ b/media-libs/mesa/mesa-24.2.6-r2.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -281,8 +281,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.7.ebuild b/media-libs/mesa/mesa-24.2.7.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.7.ebuild
+++ b/media-libs/mesa/mesa-24.2.7.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.2.8.ebuild b/media-libs/mesa/mesa-24.2.8.ebuild
index 5c33234f9ba3..c3075d910f97 100644
--- a/media-libs/mesa/mesa-24.2.8.ebuild
+++ b/media-libs/mesa/mesa-24.2.8.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -277,8 +277,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.3.0.ebuild b/media-libs/mesa/mesa-24.3.0.ebuild
index 8cb69ed47935..23476336a9f6 100644
--- a/media-libs/mesa/mesa-24.3.0.ebuild
+++ b/media-libs/mesa/mesa-24.3.0.ebuild
@@ -97,7 +97,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -276,8 +276,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-24.3.0_rc2.ebuild b/media-libs/mesa/mesa-24.3.0_rc2.ebuild
index 8cb69ed47935..23476336a9f6 100644
--- a/media-libs/mesa/mesa-24.3.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-24.3.0_rc2.ebuild
@@ -97,7 +97,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -276,8 +276,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 8cb69ed47935..23476336a9f6 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -97,7 +97,7 @@ RDEPEND="
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
llvm? (
$(llvm_gen_dep "
- sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ llvm-core/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
opencl? (
dev-util/spirv-llvm-translator:\${LLVM_SLOT}
llvm-core/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
@@ -276,8 +276,8 @@ python_check_deps() {
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
- ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ if use llvm && has_version llvm-core/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and llvm-core/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi